zoukankan      html  css  js  c++  java
  • HDOJ 1224 Free DIY Tour

    简单DP

    Free DIY Tour

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 2550    Accepted Submission(s): 838


    Problem Description
    Weiwei is a software engineer of ShiningSoft. He has just excellently fulfilled a software project with his fellow workers. His boss is so satisfied with their job that he decide to provide them a free tour around the world. It's a good chance to relax themselves. To most of them, it's the first time to go abroad so they decide to make a collective tour.

    The tour company shows them a new kind of tour circuit - DIY circuit. Each circuit contains some cities which can be selected by tourists themselves. According to the company's statistic, each city has its own interesting point. For instance, Paris has its interesting point of 90, New York has its interesting point of 70, ect. Not any two cities in the world have straight flight so the tour company provide a map to tell its tourists whether they can got a straight flight between any two cities on the map. In order to fly back, the company has made it impossible to make a circle-flight on the half way, using the cities on the map. That is, they marked each city on the map with one number, a city with higher number has no straight flight to a city with lower number. 

    Note: Weiwei always starts from Hangzhou(in this problem, we assume Hangzhou is always the first city and also the last city, so we mark Hangzhou both 1 andN+1), and its interesting point is always 0.

    Now as the leader of the team, Weiwei wants to make a tour as interesting as possible. If you were Weiwei, how did you DIY it?
     

    Input
    The input will contain several cases. The first line is an integer T which suggests the number of cases. Then T cases follows.
    Each case will begin with an integer N(2 ≤ N ≤ 100) which is the number of cities on the map.
    Then N integers follows, representing the interesting point list of the cities.
    And then it is an integer M followed by M pairs of integers [Ai, Bi] (1 ≤ i ≤ M). Each pair of [Ai, Bi] indicates that a straight flight is available from City Ai to City Bi.
     

    Output
    For each case, your task is to output the maximal summation of interesting points Weiwei and his fellow workers can get through optimal DIYing and the optimal circuit. The format is as the sample. You may assume that there is only one optimal circuit. 

    Output a blank line between two cases.
     

    Sample Input
    230 70 9041 21 32 43 430 90 7041 21 32 43 4
     

    Sample Output
    CASE 1#points : 90circuit : 1->3->1CASE 2#points : 90circuit : 1->2->1
     

    Author
    JGShining(极光炫影)
     

    Source
     

    Recommend
    Ignatius.L
     


    #include <iostream>
    #include <cstdio>
    #include <cstring>

    using namespace std;

    int vis[111][111];  ///vis[a]
    int dp[111];
    int f[111];
    int p[111];
    int T,n,m;

    int main()
    {
    int cur=0;
    cin>>T;
    while(T--)
    {
        memset(dp,0,sizeof(dp));
        memset(vis,0,sizeof(vis));
        memset(p,0,sizeof(p));
        cin>>n;
        for(int i=0;i<=n+1;i++)
            f=i;
        for(int i=1;i<=n;i++)
            cin>>p;
        cin>>m;
        int a,b;
        for(int i=0;i<m;i++)
        {
            cin>>a>>b;
            vis[a]=1;
        }

        for(int i=2;i<=n+1;i++)
        {
            int ma=-999;
            for(int j=0;j<i;j++)
            {
                if(vis[j])
                    if(dp[j]>ma)
                    {
                        f=j;
                        ma=dp[j];
                    }
            }
            if(ma==-999) ma=0;
            dp=ma+p;
        }
    /*
    for(int i=0;i<=n+1;i++)
        cout<<dp<<" ";
    cout<<"\n-------------"<<endl;
    */
       int cnt=1;
       int aa[111];
       memset(aa,0,sizeof(aa));
       aa[0]=1;
       int k=n+1;
       while(f[k]!=k)
       {
           aa[cnt]=f[k];
           k=f[k];
           cnt++;
       }
    /*
       for(int i=0;i<cnt;i++)
        cout<<aa<<" ";
        cout<<endl;
    */
       printf("CASE %d#\n",++cur);
       printf("points : %d\n",dp[n+1]);
       printf("circuit : ");
       for(int i=cnt-1;i>=0;i--)
       {
           cout<<aa;
           if(i!=0)  cout<<"->";
       }
       cout<<endl;
       if(T!=0)
       cout<<endl;
    }

        return 0;
    }

  • 相关阅读:
    Git删除不存在对应远程分支的本地分支
    Git删除远程分支
    将博客搬至CSDN
    HttpStatus
    Mysql 日期
    jekyll开发静态网站
    修改maven默认的jdk版本
    使用@Value进行静态常量的值注入
    妙笔生花处,惊艳四座
    Integer 和 int 值比较
  • 原文地址:https://www.cnblogs.com/CKboss/p/3351034.html
Copyright © 2011-2022 走看看