zoukankan      html  css  js  c++  java
  • HDOJ 2845 Beans


    不能取相邻的行或列对行和列分别DP,【0】:没取的最大值,【1】:取的最大值

     

    Beans

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 1963    Accepted Submission(s): 993


    Problem Description
    Bean-eating is an interesting game, everyone owns an M*N matrix, which is filled with different qualities beans. Meantime, there is only one bean in any 1*1 grid. Now you want to eat the beans and collect the qualities, but everyone must obey by the following rules: if you eat the bean at the coordinate(x, y), you can’t eat the beans anyway at the coordinates listed (if exiting): (x, y-1), (x, y+1), and the both rows whose abscissas are x-1 and x+1.
    HDOJ 2845 Beans - qhn999 - 码代码的猿猿


    Now, how much qualities can you eat and then get ?
     

    Input
    There are a few cases. In each case, there are two integer M (row number) and N (column number). The next M lines each contain N integers, representing the qualities of the beans. We can make sure that the quality of bean isn't beyond 1000, and 1<=M*N<=200000.
     

    Output
    For each case, you just output the MAX qualities you can eat and then get.
     

    Sample Input
    4 6
    11 0 7 5 13 9
    78 4 81 6 22 4
    1 40 9 34 16 10
    11 22 0 33 39 6
     

    Sample Output
    242
     

    Source
     

    Recommend
    gaojie
     

    #include <iostream>
    #include <cstdio>

    using namespace std;

    const int maxn=222222;

    int a[maxn],dp[maxn][2];
    int N,M;

    int main()
    {
    while(scanf("%d%d",&M,&N)!=EOF)
    {
        for(int i=1;i<=M;i++)
        {
            for(int j=1;j<=N;j++)
            {
                int k;
                scanf("%d",&k);
                if(j<=1)
                {
                    dp[j][1]=k;
                }
                else
                {
                    dp[j][0]=max(dp[j-1][0],dp[j-1][1]);
                    dp[j][1]=dp[j-1][0]+k;
                }
            }
            a=max(dp[N][0],dp[N][1]);
        }

        for(int i=1;i<=M;i++)
        {
            if(i==0||i==1)
            {
                dp[0]=0;
                dp[1]=a;
            }
            else
            {
                dp[0]=max(dp[i-1][0],dp[i-1][1]);
                dp[1]=dp[i-1][0]+a;
            }
        }

        int ans=max(dp
    [0],dp
    [1]);
        cout<<ans<<endl;

    }


        return 0;
    }
     

  • 相关阅读:
    通信—互联网协议入门2(转载)
    通信—互联网协议入门1(转载)
    通信—HTTP 协议入门(转载)
    通信—跨域资源共享
    ionic3使用echart插件
    通信—HTTP与HTTPS
    ionic学习笔记—常用命令
    ionic学习笔记—创建项目
    Spark 资源池简介
    数据库设计原则
  • 原文地址:https://www.cnblogs.com/CKboss/p/3351047.html
Copyright © 2011-2022 走看看