zoukankan      html  css  js  c++  java
  • POJ 1141 Brackets Sequence


    Brackets Sequence
    Time Limit: 1000MSMemory Limit: 65536K
    Total Submissions: 21666Accepted: 6068Special Judge

    Description

    Let us define a regular brackets sequence in the following way: 

    1. Empty sequence is a regular sequence. 
    2. If S is a regular sequence, then (S) and [S] are both regular sequences. 
    3. If A and B are regular sequences, then AB is a regular sequence. 

    For example, all of the following sequences of characters are regular brackets sequences: 

    (), [], (()), ([]), ()[], ()[()] 

    And all of the following character sequences are not: 

    (, [, ), )(, ([)], ([(] 

    Some sequence of characters '(', ')', '[', and ']' is given. You are to find the shortest possible regular brackets sequence, that contains the given character sequence as a subsequence. Here, a string a1 a2 ... an is called a subsequence of the string b1 b2 ... bm, if there exist such indices 1 = i1 < i2 < ... < in = m, that aj = bij for all 1 = j = n.

    Input

    The input file contains at most 100 brackets (characters '(', ')', '[' and ']') that are situated on a single line without any other characters among them.

    Output

    Write to the output file a single line that contains some regular brackets sequence that has the minimal possible length and contains the given sequence as a subsequence.

    Sample Input

    ([(]

    Sample Output

    ()[()]

    Source


    #include <iostream>
    #include <cstring>
    #include <cstdio>

    using namespace std;

    const int maxn=111;

    int dp[maxn][maxn],path[maxn][maxn];
    char str[maxn];

    void print(int i,int j)
    {
        if(i>j) return ;
        else if(i==j)
        {
            if(str=='['||str==']') printf("[]");
            else printf("()");
        }
        else if(path[j]==-1)
        {
            printf("%c",str);
            print(i+1,j-1);
            printf("%c",str[j]);
        }
        else
        {
            int k=path[j];
            print(i,k);
            print(k+1,j);
        }

    }

    int main()
    {
        while(gets(str))
        {
            int n=strlen(str);

            if(n==0) { putchar(10);continue; }

            memset(dp,0,sizeof(dp));

            for(int i=0;i<n;i++)  dp=1;

            for(int r=1;r<n;r++)
            for(int i=0;i<n-r;i++)
            {
                int j=i+r;
                dp[j]=999999999;
                if((str=='['&&str[j]==']')||(str=='('&&str[j]==')'))
                    if(dp[j]>dp[i+1][j-1])
                        dp[j]=dp[i+1][j-1],path[j]=-1;

                for(int k=i;k<j;k++)
                    if(dp[j]>(dp[k]+dp[k+1][j]))
                    dp[j]=dp[k]+dp[k+1][j],path[j]=k;
            }

            print(0,n-1);
            putchar(10);
        }

        return 0;
    }

  • 相关阅读:
    OC学习笔记
    feed43+ifttt
    让Hyper-V和VMware虚拟机软件共存
    ios问题集
    vs2012问题集
    第二个win8应用制作笔记
    隐私策略
    《龙泉青瓷》隐私策略
    win8开发-Xaml学习笔记四
    梦想成为“老板”的第N天
  • 原文地址:https://www.cnblogs.com/CKboss/p/3351056.html
Copyright © 2011-2022 走看看