zoukankan      html  css  js  c++  java
  • POJ 3273 Monthly Expense

    二分搜索,找小的值
    Monthly Expense
    Time Limit: 2000MSMemory Limit: 65536K
    Total Submissions: 10057Accepted: 4114

    Description

    Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

    FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

    FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

    Input

    Line 1: Two space-separated integers: N and M 
    Lines 2..N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day

    Output

    Line 1: The smallest possible monthly limit Farmer John can afford to live with.

    Sample Input

    7 5100400300100500101400

    Sample Output

    500

    Hint

    If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.

    Source

    USACO 2007 March Silver




    #include <iostream>

    using namespace std;

    int a[110000];

    int main()
    {
    int n,m;
    int Max=-1,Min=0,Mid;
    cin>>n>>m;
    for(int i=0;i<n;i++)
    {
    cin>>a;
    Max+=a;
    if(a>Min)
    {
    Min=a;
    }
    }

    while(Max>Min)
    {
    Mid=(Max+Min)/2;
    //cout<<Min<<"  "<<Mid<<"  "<<Max<<" day: ";

    int day=0,money=Mid;
    for(int i=0;i<n;i++)
    {
       if(money-a>=0)
                {
                    money-=a;
                }
                else
                {
                    day++;
                    money=Mid;
                    i--;//一定要退回去!!
                }
    }

    //cout<<day<<endl;

    if(day+1>m)
    {
    Min=Mid+1;
    }
    else if(day+1<=m)
    {
    Max=Mid;
    }
    }

    //cout<<Min<<"  "<<Max<<endl;

    cout<<(Min+Max)/2<<endl;

    return 0;
    }
     
  • 相关阅读:
    模态框获取内容jQuery
    jQuery支持链式编程,一句话实现左侧table页+常用筛选器总结
    jquery实现全选、取消反选、加JavaScript三元运算(三种法法实现反选)
    用dom1来实现,根据光标移动自动给表单加上背景色,光标移开自动去除背景色
    JavaScript两种创建标签的的方法,实现点击按钮让text自增
    vue前端路由搜索功能实现
    pycharm配置vue
    QT全局事件和绑定
    mysql事务、锁
    web前端上传文件按钮自定义样式
  • 原文地址:https://www.cnblogs.com/CKboss/p/3351091.html
Copyright © 2011-2022 走看看