zoukankan      html  css  js  c++  java
  • 【BZOJ3943】[Usaco2015 Feb]SuperBull 最大生成树

    【BZOJ3943】[Usaco2015 Feb]SuperBull

    Description

    Bessie and her friends are playing hoofball in the annual Superbull championship, and Farmer John is in charge of making the tournament as exciting as possible. A total of N (1 <= N <= 2000) teams are playing in the Superbull. Each team is assigned a distinct integer team ID in the range 1...2^30-1 to distinguish it from the other teams. The Superbull is an elimination tournament -- after every game, Farmer John chooses which team to eliminate from the Superbull, and the eliminated team can no longer play in any more games. The Superbull ends when only one team remains.Farmer John notices a very unusual property about the scores in
    matches! In any game, the combined score of the two teams always ends up being the bitwise exclusive OR (XOR) of the two team IDs. For example, if teams 12 and 
    20 were to play, then 24 points would be scored in that game, since 01100 XOR 10100 = 11000.Farmer John believes that the more points are scored in a game, the more exciting the game is. Because of this, he wants to choose a series of games to be played such that the total number of points scored in the Superbull is maximized. Please help Farmer John organize the matches.
    贝西和她的朋友们在参加一年一度的“犇”(足)球锦标赛。FJ的任务是让这场锦标赛尽可能地好看。一共有N支球队参加这场比赛,每支球队都有一个特有的取值在1-230-1之间的整数编号(即:所有球队编号各不相同)。“犇”锦标赛是一个淘汰赛制的比赛——每场比赛过后,FJ选择一支球队淘汰,淘汰了的球队将不能再参加比赛。锦标赛在只有一支球队留下的时候就结束了。FJ发现了一个神奇的规律:在任意一场比赛中,这场比赛的得分是参加比赛两队的编号的异或(Xor)值。例如:编号为12的队伍和编号为20的队伍之间的比赛的得分是24分,因为 12(01100) Xor 20(10100) = 24(11000)。FJ相信比赛的得分越高,比赛就越好看,因此,他希望安排一个比赛顺序,使得所有比赛的得分和最高。请帮助FJ决定比赛的顺序

    Input

    The first line contains the single integer N. The following N lines contain the N team IDs.
    第一行包含一个整数N接下来的N行包含N个整数,第i个整数代表第i支队伍的编号, 1<=N<=2000

    Output

    Output the maximum possible number of points that can be scored in the Superbull.
    一行,一个整数,表示锦标赛的所有比赛的得分的最大值

    Sample Input

    4
    3
    6
    9
    10

    Sample Output

    37

    HINT

    样例解释:

    FJ先让编号为3和编号为9的队伍进行比赛,然后让编号为9的队伍赢得比赛(淘汰编号为6的队伍),现在

    剩下了编号为6910的队伍。然后他让编号为6和编号为9的队伍比赛,然后让编号为6的队伍赢得比赛。现在编号为6

    10的队伍留了下来最后让编号为6和编号为10的队伍比赛,让编号为10的队伍赢得比赛。所有比赛的得分和就是:(

    3Xor9)+(6Xor9)+(6Xor10)=10+15+12=37

    题解:本题看起来很麻烦,但我们发现n只有2000,于是想到可以把所有牛当成点,所有比赛当成边,然后跑一遍最大生成树就可以了。

    #include<stdio.h>
    #include<iostream>
    #include<algorithm>
    using namespace std;
    int n,m,sum;
    long long ans;
    struct match
    {
        int from,to,val;
    }s[2010*2010];
    int p[2010],f[2010];
    bool cmp(match a,match b)
    {
        return a.val>b.val;
    }
    int find(int x)
    {
        if(f[x]!=x)
        f[x]=find(f[x]);
        return f[x];
    }
    int main()
    {
        scanf("%d",&n);
        int i,j,ra,rb;
        for(i=1;i<=n;i++)
        {
            f[i]=i;
            scanf("%d",&p[i]);
            for(j=1;j<i;j++)
            {
                s[m].from=j;
                s[m].to=i;
                s[m++].val=p[i]^p[j];
            }
        }
        sort(s,s+m,cmp);
        for(i=0;i<m;i++)
        {
            ra=find(s[i].from);
            rb=find(s[i].to);
            if(ra!=rb)
            {
                f[ra]=rb;
                ans+=(long long)s[i].val;
                sum++;
                if(sum==n-1)
                break;
            }
        }
        printf("%lld",ans);
        return 0;
    }
  • 相关阅读:
    字符串转json
    如何解决写好的脚本上传Linux执行出错?
    Windows查看端口并开放端口
    解决mysql遇到非root权限无法登录mysql数据库的问题
    raid配置
    Python实现根据时间移动/复制一个文件夹的文件--模拟大并发数据
    ffmpeg基本命令学习
    pytest学习--pytest的skip和skipif
    多项式全家桶学习笔记(How EI's poly works)
    具体数学难度评分
  • 原文地址:https://www.cnblogs.com/CQzhangyu/p/6256778.html
Copyright © 2011-2022 走看看