zoukankan      html  css  js  c++  java
  • HDU6025 Coprime Sequence —— 前缀和 & 后缀和

    题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=6025


    Coprime Sequence

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
    Total Submission(s): 666    Accepted Submission(s): 336


    Problem Description
    Do you know what is called ``Coprime Sequence''? That is a sequence consists of n positive integers, and the GCD (Greatest Common Divisor) of them is equal to 1.
    ``Coprime Sequence'' is easy to find because of its restriction. But we can try to maximize the GCD of these integers by removing exactly one integer. Now given a sequence, please maximize the GCD of its elements.
     

    Input
    The first line of the input contains an integer T(1T10), denoting the number of test cases.
    In each test case, there is an integer n(3n100000) in the first line, denoting the number of integers in the sequence.
    Then the following line consists of n integers a1,a2,...,an(1ai109), denoting the elements in the sequence.
     

    Output
    For each test case, print a single line containing a single integer, denoting the maximum GCD.
     

    Sample Input
    3 3 1 1 1 5 2 2 2 3 2 4 1 2 4 8
     

    Sample Output
    1 2 2
     



    题解:

    l[i]为前i个数的gcd, r[i]为后i个数的gcd。

    假设被删除的数的下标为i, 则 删除该数后的gcd为: gcd(l[i-1], r[i+1]), 枚举i,取最大值。



    学习之处:

    当提到在序列里删除一段连续的数时,可以用前缀和+后缀和

    例如:http://blog.csdn.net/dolfamingo/article/details/71001021



    代码如下:

    #include<bits/stdc++.h>
    using namespace std;
    typedef long long LL;
    const double eps = 1e-6;
    const int INF = 2e9;
    const LL LNF = 9e18;
    const int mod = 1e9+7;
    const int maxn = 1e5+10;
    
    int n;
    int a[maxn], l[maxn], r[maxn];
    
    int gcd(int a, int b)
    {
        return b==0?a:(gcd(b,a%b));
    }
    
    void solve()
    {
        scanf("%d",&n);
        for(int i = 1; i<=n; i++)
            scanf("%d",&a[i]);
    
        l[1] = a[1]; r[n] = a[n];
        for(int i = 2; i<=n; i++)
            l[i] = gcd(l[i-1], a[i]);
        for(int i = n-1; i>=1; i--)
            r[i] = gcd(r[i+1], a[i]);
    
        int ans = 1;
        l[0] = a[2]; r[n+1] = a[n-1];
        for(int i = 1; i<=n; i++)
            ans = max(ans, gcd(l[i-1], r[i+1]) );
        cout<<ans<<endl;
    }
    
    int main()
    {
        int T;
        scanf("%d",&T);
        while(T--)
        {
            solve();
        }
        return 0;
    }
    


  • 相关阅读:
    读 Kafka 源码写优雅业务代码:配置类
    如何安装FTP服务器,并实现文件共享
    Merge into用法总结
    Insomnia 跟 Postman 类似的软件
    iOS dealloc中初始化weak指针崩溃防护
    Centos7安装febootstrap
    获取 linux 系统 CPU、内存、磁盘 IO 等信息的脚本
    Git本地远程仓库
    网络及服务故障的排查思路
    Git配置远程仓库(密匙链接)
  • 原文地址:https://www.cnblogs.com/DOLFAMINGO/p/7538680.html
Copyright © 2011-2022 走看看