zoukankan      html  css  js  c++  java
  • POJ 1860 Currency Exchange

    Currency Exchange
    Time Limit: 1000MS   Memory Limit: 30000K
    Total Submissions: 35676   Accepted: 13672

    Description

    Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency.
    For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR.
    You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real RAB, CAB, RBA and CBA - exchange rates and commissions when exchanging A to B and B to A respectively.
    Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations.

    Input

    The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=103.
    For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10-2<=rate<=102, 0<=commission<=102.
    Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 104.

    Output

    If Nick can increase his wealth, output YES, in other case output NO to the output file.

    Sample Input

    3 2 1 20.0
    1 2 1.00 1.00 1.00 1.00
    2 3 1.10 1.00 1.10 1.00
    

    Sample Output

    YES

    题目大意:第一行给予 n(钞票种类) m(兑换途径) s(初始持有的钞票种类) v(面值)
        第二行开始给予对m条路的描述
        from-to cost-rate(正) cost-rate(反)
        每一条路按规则 dis[to] = (dis[from]-cost)*rate的规则进行变换,问最后能否使手中的财富增加
    解决:Bellman_ford算法解决判断负环的的问题,可以对其做一点修改判断正环。


    #include <iostream>
    #include <cstring>
    #include <cstdio>
    using namespace std;
    #define N 105
    struct Edge{
        int from,to;
        double cost,rate;
    }edge[N<<1];
    int cnt;
    int n,m,s;
    double sta;
    double dis[N];
    void add_(int u,int v, double r,double c){
        ++cnt;
        edge[cnt].from = u;
        edge[cnt].to = v;
        edge[cnt].cost = c;
        edge[cnt].rate = r;
    }
    void init(){
        cnt = 0;
        memset(dis,0, sizeof(dis));
        int u,v;
        double a,b;
        while(m--){
            scanf("%d %d %lf %lf",&u,&v,&a,&b);
            add_(u,v,a,b);
            scanf("%lf %lf",&a,&b);
            add_(v,u,a,b);
        }
    }
    bool bellman_ford(){
        dis[s] = sta;
        bool flag;
        for(int o =  1 ; o <= n - 1 ; ++o){
            flag = false;
            for(int i = 1 ; i <= cnt ; ++i){
                int v = edge[i].to,u = edge[i].from;
                if(dis[v] < ((dis[u] - edge[i].cost)*edge[i].rate)){
                    dis[v] = (dis[u] - edge[i].cost)*edge[i].rate;
                    flag = true;
                }
            }
            if(!flag)break;
        }
        for(int i = 1 ; i <= cnt ; ++i){
            int v = edge[i].to,u = edge[i].from;
            if(dis[v] < ((dis[u] - edge[i].cost)*edge[i].rate)){
                return true;
            }
        }
        return false;
    }
    int main(){
        while (cin>>n>>m>>s>>sta){
            init();
            if(bellman_ford())puts("YES");
            else puts("NO");
        }
        return 0;
    }
    
    
    



  • 相关阅读:
    ADO.NET 根据实体类自动生成添加修改语句仅限Oracle使用
    C# 实体对象作为参数统一去除空格
    jQuery 前端复选框 全选 反选 下拉菜单联动
    C# 后台服务器端 Get 请求函数封装
    服务器404错误页面
    vue 封装公用函数
    Vue 生命周期
    Oracle 查看表结构
    ubuntu源配置
    外观(Facade)模式
  • 原文地址:https://www.cnblogs.com/DevilInChina/p/9373349.html
Copyright © 2011-2022 走看看