zoukankan      html  css  js  c++  java
  • 【欧拉函数筛】Visible Lattice Points

    题目描述

    A lattice point (x, y) in the first quadrant (x and y are integers greater than or equal to 0), other than the origin, is visible from the origin if the line from (0, 0) to (x, y) does not pass through any other lattice point. For example, the point (4, 2) is not visible since the line from the origin passes through (2, 1). The figure below shows the points (x, y) with 0 ≤ x, y ≤ 5 with lines from the origin to the visible points.

    Write a program which, given a value for the size, N, computes the number of visible points (x, y) with 0 ≤ x, y ≤ N.

    输入

    The first line of input contains a single integer C (1 ≤ C ≤ 1000) which is the number of datasets that follow.
    Each dataset consists of a single line of input containing a single integer N (1 ≤ N ≤ 1000), which is the size.

    输出

    For each dataset, there is to be one line of output consisting of: the dataset number starting at 1, a single space, the size, a single space and the number of visible points for that size.

    样例输入

    4
    2
    4
    5
    231
    

    样例输出

    1 2 5
    2 4 13
    3 5 21
    4 231 32549



    #include <bits/stdc++.h>
    #define ll long long
    #define ull unsigned long long
    #define ld long double
    using namespace std;
    const int maxn=10000;
    int n,c;
    int ret[maxn];
    int prime[maxn],phi[maxn],ant,ans;
    bool isprime[maxn];
    void getphi()
    {
        phi[1]=1;
        for(int i=2;i<=maxn;i++)
        {
            if(!isprime[i])
            {
                prime[++ant]=i;
                phi[i]=i-1;
            }
            for(int j=1;j<=ant;j++)
            {
                if(i*prime[j]>maxn)
                    break;
                isprime[i*prime[j]]=1;
                if(i%prime[j]==0)
                {
                    phi[i*prime[j]]=phi[i]*prime[j];
                    break;
                }
                else
                {
                    phi[i*prime[j]]=phi[i]*(prime[j]-1);
                }
            }
        }
    }
    int main()
    {
        getphi();
        for(int i=1;i<=maxn;i++)
        {
            ret[i]=phi[i]+ret[i-1];
        }
        cin>>c;
        int t=1;
        while(c--)
        {
            cin>>n;
            int pos=0;
            cout<<t<<" "<<n<<" "<<(2*ret[n]+1)<<endl;
            t++;
        }
        return 0;
    }
  • 相关阅读:
    联考20200725 T1 String
    联考20200723 T1 数
    联考20200722 T3 积木
    联考20200722 T2 ACT4!无限回转!
    联考20200722 T1 集合划分
    联考20200721 T2 s2mple
    联考20200721 T1 s1mple
    联考20200719 T2 寻找规律
    联考20200719 T1 合并奶牛
    联考20200718 T2 树论
  • 原文地址:https://www.cnblogs.com/Diliiiii/p/9516005.html
Copyright © 2011-2022 走看看