zoukankan      html  css  js  c++  java
  • hdu1240 三维bfs最短路径

    Asteroids!

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 4595    Accepted Submission(s): 2962

    Input
    Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets.

    A single data set has 5 components:

    Start line - A single line, "START N", where 1 <= N <= 10.

    Slice list - A series of N slices. Each slice is an N x N matrix representing a horizontal slice through the asteroid field. Each position in the matrix will be one of two values:

    'O' - (the letter "oh") Empty space

    'X' - (upper-case) Asteroid present

    Starting Position - A single line, "A B C", denoting the <A,B,C> coordinates of your craft's starting position. The coordinate values will be integers separated by individual spaces.

    Target Position - A single line, "D E F", denoting the <D,E,F> coordinates of your target's position. The coordinate values will be integers separated by individual spaces.

    End line - A single line, "END"

    The origin of the coordinate system is <0,0,0>. Therefore, each component of each coordinate vector will be an integer between 0 and N-1, inclusive.

    The first coordinate in a set indicates the column. Left column = 0.

    The second coordinate in a set indicates the row. Top row = 0.

    The third coordinate in a set indicates the slice. First slice = 0.

    Both the Starting Position and the Target Position will be in empty space.
     
     
    Output
    For each data set, there will be exactly one output set, and there will be no blank lines separating output sets.

    A single output set consists of a single line. If a route exists, the line will be in the format "X Y", where X is the same as N from the corresponding input data set and Y is the least number of moves necessary to get your ship from the starting position to the target position. If there is no route from the starting position to the target position, the line will be "NO ROUTE" instead.
    A move can only be in one of the six basic directions: up, down, left, right, forward, back. Phrased more precisely, a move will either increment or decrement a single component of your current position vector by 1.
     
     
    Sample Input
    START 1
    O
    0 0 0
    0 0 0
    END
    START 3
    XXX
    XXX
    XXX
    OOO
    OOO
    OOO
    XXX
    XXX
    XXX
    0 0 1
    2 2 1
    END
    START 5
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    XXXXX
    XXXXX
    XXXXX
    XXXXX
    XXXXX
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    0 0 0 
    4 4 4
    END
     

    Sample Output
    1 0
    3 4
    NO ROUTE


    很基础吧,不过我忘了优先队列每次出队时清零,搞了一会,还是1a了
     

    #include <iostream>
    #include <cstdio>
    #include <cmath>
    #include <cstring>
    #include <cstring>
    #include <algorithm>
    #include <stack>
    #include <queue>
    #include <string>
    
    const int inf = (1<<31)-1;
    const int MAXN  = 1e1;
    
    using namespace std;
    
    struct step{
        int x;
        int y;
        int z;
        int t;
    };
    
    int mov[6][3]={0,0,1,0,0,-1,0,1,0,0,-1,0,1,0,0,-1,0,0};
    char G[MAXN][MAXN][MAXN];//3 SLICES
    int n;
    
    queue<step>q;
    
    int check(int x,int y,int z){
        if(x<0||x>=n||y<0||y>=n||z<0||z>=n)return 0;
        if(G[z][x][y]=='X')return 0;
        else return 1;
    }
    
    int main()
    {
        char ts[10];
        int sx,sy,sz;
        int dx,dy,dz;
        while(scanf("%s%d",ts,&n)!=EOF){
           // memset(vist,0,sizeof(vist));
           /* cout<<n;
            cout<<endl<<ts<<endl;*/
            int flag = -1;
            for(int i=0;i<n;i++){
                for(int j=0;j<n;j++){
                    scanf("%s",G[i][j]);
                }
            }
           /* cout<<"debug"<<endl;
            for(int i=0;i<n;i++){
                for(int j=0;j<n;j++)
                    cout<<G[i][j]<<endl;
            }*/
            scanf("%d%d%d",&sx,&sy,&sz);
            scanf("%d%d%d",&dx,&dy,&dz);
            scanf("%s",ts);
           // cout<<ts<<endl;
         //   cout<<"debug"<<endl;
            step tp,fro;
            tp.x = sx;
            tp.y = sy;
            tp.z = sz;
            tp.t = 0;
            q.push(tp);
            int nx,ny,nz;
            while(!q.empty()){
                fro = q.front();
                q.pop();
                G[fro.z][fro.x][fro.y] = 'X';//出队清零
                if(fro.x==dx&&fro.y==dy&&fro.z==dz){
                    flag = fro.t;
                    break;
                }
                for(int i=0;i<6;i++){
                    nx = fro.x+mov[i][0];
                    ny = fro.y+mov[i][1];
                    nz = fro.z+mov[i][2];
                    if(check(nx,ny,nz)){
                        tp.x = nx;
                        tp.y = ny;
                        tp.z = nz;
                        tp.t = fro.t+1;
                        q.push(tp);
                    }
                }
            }
            while(!q.empty()){
                q.pop();
            }
            if(flag!=-1){
                cout<<n<<" "<<flag<<endl;
            }else{
                cout<<"NO ROUTE"<<endl;
            }
        }
    
       // cout << "Hello world!" << endl;
        return 0;
    }
    View Code
    在一个谎言的国度,沉默就是英雄
  • 相关阅读:
    iOS如何获取蓝牙Mac地址
    iOS完整App资源收集
    四月兄弟AprilBeacon
    图片360°旋转动画(
    图片圆角
    获取子字符串在元字符串中出现的所有位置
    调用系统震动 循环震动
    ibecon后台运行
    uiwebview 加载本地js、css、img,html从网站加载
    获取蓝牙mac地址
  • 原文地址:https://www.cnblogs.com/EdsonLin/p/5432362.html
Copyright © 2011-2022 走看看