zoukankan      html  css  js  c++  java
  • PAT 甲级1001 A+B Format (20)(C++ -思路)

    1001 A+B Format (20)(20 分)

    Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

    Input

    Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

    Output

    For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

    Sample Input

    -1000000 9
    

    Sample Output

    -999,991

    这里由于要在数字间加逗号,所以这里把数字和转化为字符串的形式(分离符号方便直接对数字操作,避免符号占1位导致后面位数判断出错)

     注意:1、当数字>=0不需要+(=0:测试点4

    #include<iostream>
    #include<string>
    using namespace std;
    int main() {
    	int a, b;
    	cin >> a >> b;
    	string ch = a + b >= 0 ? "" : "-";   //分离符号
    	string sum = to_string(abs(a + b));
    	int k = 1;
    	for (int i = sum.length() - 1; i >= 0; k++, i--) {   //每3位加",",除首位
    		if (k % 3 == 0 && i)
    			sum.insert(i, ",");
    	}
    	cout << ch + sum;    //输出数字
    	return 0;
    }
    
  • 相关阅读:
    使用jackson美化输出json/xml
    mybatis不报错,但是查询结果为0
    @Valid基于hibernate
    spring 整合 mybatis (不含物理分页)
    mybatis insert 自动生成key
    mybatis 配置延迟加载 和 缓存
    mybaits foreach
    2015-08-13T17:39:15
    Introduction
    mybatis 存储过程调用
  • 原文地址:https://www.cnblogs.com/F-itachi/p/9974392.html
Copyright © 2011-2022 走看看