zoukankan      html  css  js  c++  java
  • PAT 1044 火星数字(20)(思路+代码)

    1044 火星数字(20)(20 分)

    火星人是以13进制计数的:

    • 地球人的0被火星人称为tret。
    • 地球人数字1到12的火星文分别为:jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec。
    • 火星人将进位以后的12个高位数字分别称为:tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou。

    例如地球人的数字“29”翻译成火星文就是“hel mar”;而火星文“elo nov”对应地球数字“115”。为了方便交流,请你编写程序实现地球和火星数字之间的互译。

    输入格式:

    输入第一行给出一个正整数N(<100),随后N行,每行给出一个[0, 169)区间内的数字 —— 或者是地球文,或者是火星文。

    输出格式:

    对应输入的每一行,在一行中输出翻译后的另一种语言的数字。

    输入样例:

    4
    29
    5
    elo nov
    tam
    

    输出样例:

    hel mar
    may
    115
    13

     PS:

       代码主要有2个功能:

                    1、地球数字转火星文

                                 可以将数字转化成13进制的数,然后将每一位作为下标,输出对应字符。

                    2、火星文转地球数字。

                                 有两种可能,可能有一位或者两位火星文,综合一下,可以第一次取字符串末三位进行匹配,如果字符串长度                      比4大,则说明还有一位火星文,再取字符串前三位,进行匹配,最后得到地球数字。

                        

    #include<iostream>
    #include<string>
    #include<algorithm>
    using namespace std;
    int main()
    {
    	string one[13] = { "tret" ,"jan", "feb", "mar","apr","may", "jun", "jly","aug", "sep", "oct", "nov","dec" },
    		two[13] = { "tret","tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou" };
    	int n, sum = 0,res;
    	string m;
    	cin >> n;
    	getchar();    //清除缓存(之前的回车键)
    	while (n--) {
    		getline(cin, m);
    		if (isdigit(m[0])) {        //地球->火星
    			res = atoi(m.c_str());	
    			if (res/13)
    				cout << two[res/13];
    			if (res / 13 && res % 13)
    				cout << " "<< one[res % 13];
    			if (!(res/13))
    				cout << one[res % 13];
    			cout << endl;
    		}
    		else {                    //火星->地球
    			for (int i = 0; i < 13; i++) {
    				if (m.substr(m.length() - 3,m.length()) == one[i]) {
    					sum += i;
    					break;
    				}			
    				else if (m.substr(m.length() - 3, m.length()) == two[i]) {
    					sum += (i*13);
    					break;
    				}
    			}
    			if (m.length() > 4) {
    				for (int i = 0; i < 13; i++) {
    					if (m.substr(0, 3) == two[i]) {
    						sum += i * 13;
    						break;
    					}
    				}
    			}
    			cout << sum << endl;
    			sum = 0;
    		}
    	}
    	return 0;
    }
  • 相关阅读:
    Mac下使用SSH连接远程Linux服务器
    Kafka 中文文档
    计算器如何使用取模功能,调出程序员功能,35171799%15的结果是9
    pm2好用的node进程管理工具,监控进程开机自启动,java进程配置,安装Nodejs环境
    vuejs Mac环境下npm run serve 提示 node_modules/.bin/vue-cli-service: Permission denied问题解决方案
    0day相关信息安全技术
    零基础如何学习Web安全?
    余弦的渗透利器
    知道创宇研发技能表v3.1
    Redis主从复制、哨兵、Cluster三种模式
  • 原文地址:https://www.cnblogs.com/F-itachi/p/9974442.html
Copyright © 2011-2022 走看看