zoukankan      html  css  js  c++  java
  • C语言编程练习66:Bone Collector

    Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
    The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?



    Input
    The first line contain a integer T , the number of cases.
    Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
    Output
    One integer per line representing the maximum of the total value (this number will be less than 231).
    Sample Input
    1
    5 10
    1 2 3 4 5
    5 4 3 2 1
    Sample Output
    14

    动态规划的学习,但是我还是搞不太懂,如何推公式
    #include<stdio.h>
    #include<string.h>
    #include<algorithm>
    #include<cmath>
    #include<iostream>
    using namespace std;
    struct BONE
    {
        int val;
        int vol;
    }bone[1011];
    int N,V;
    int dp[1011][1011];
    int ans()
    {
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=N;i++)
        {
            for(int j=0;j<=V;j++)
            {
                if(bone[i].vol>j)
                {
                    dp[i][j]=dp[i-1][j];
                }
                else
                {
                    dp[i][j]=max(dp[i-1][j],dp[i-1][j-bone[i].vol]+bone[i].val);
                }
                
            }
        }
        return dp[N][V];
    }
    int main()
    {
        int t;
        cin>>t;
        while(t--)
        {
            cin>>N>>V;
            for(int i=1;i<=N;i++)
            {
                cin>>bone[i].val;
            }
            for(int i=1;i<=N;i++)
            {
                cin>>bone[i].vol;
            }
            cout<<ans()<<endl;
        }
        
        return 0;
    }
    
  • 相关阅读:
    centos7 常用工具包安装
    Java.lang.String类
    javaweb系统调优方案
    nginx 优化
    centos7 源码安装nginx
    tomcat8调优
    commons-logging slf4j log4j 区别
    docker 安装centos7并SSH远程连接
    aws mysql 开启慢查询日志, 并利用mysqlsla 分析
    centos7 源码安装goaccess
  • 原文地址:https://www.cnblogs.com/FantasticDoubleFish/p/14501995.html
Copyright © 2011-2022 走看看