zoukankan      html  css  js  c++  java
  • HDU 1159:Common Subsequence(LCS模板)

    Common Subsequence

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 48378    Accepted Submission(s): 22242

    Problem Description

    A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. 
    The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. 

    Sample Input

    abcfbc abfcab
    programming contest 
    abcd mnp

    Sample Output

    4
    2
    0

     

     

    LCS模板题,直接上代码

    #include <stdio.h>
    #include <string.h>
    #include <iostream>
    #include <algorithm>
    #include <math.h>
    #include <limits.h>
    #include <map>
    #include <stack>
    #include <queue>
    #include <vector>
    #include <set>
    #include <string>
    #define ll long long
    #define ms(a) memset(a,0,sizeof(a))
    #define pi acos(-1.0)
    #define INF 0x3f3f3f3f
    const double E=exp(1);
    const int maxn=1e3+10;
    using namespace std;
    char a[maxn],b[maxn];
    int dp[maxn][maxn];
    int main(int argc, char const *argv[])
    {
    	ios::sync_with_stdio(false);
    	while(cin>>a>>b)
    	{
    		ms(dp);
    		int la=strlen(a);
    		int lb=strlen(b);
    		for(int i=1;i<=la;i++)
    		{
    			for(int j=1;j<=lb;j++)
    			{
    				if(a[i-1]==b[j-1])
    					dp[i][j]=dp[i-1][j-1]+1;
    				else
    					dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
    			}
    		}
    		cout<<dp[la][lb]<<endl;
    	}
    	return 0;
    }
    
  • 相关阅读:
    Coin-row problem(1139)
    算法的稳定性
    折半查找的实现(1010)swust-oj
    判断回文(0315)SWUST-OJ
    逆置单链表(0957)swust-oj
    单链表上查找算法的实现(0955) swust-oj
    单链表的插入操作的实现(0952)SUWST-OJ
    单链表的链接(0954)swust-oj
    单链表的删除操作的实现(0953)swust-oj
    ASP.net core 2.0.0 中 asp.net identity 2.0.0 的基本使用(三)—用户账户及cookie配置
  • 原文地址:https://www.cnblogs.com/Friends-A/p/10324406.html
Copyright © 2011-2022 走看看