zoukankan      html  css  js  c++  java
  • HDU 1017 A Mathematical Curiosity

    A Mathematical Curiosity

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 21866    Accepted Submission(s): 6853

    Problem Description
    Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.
    This problem contains multiple test cases!
    The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.
    The output format consists of N output blocks. There is a blank line between output blocks.
     
    Input
    You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.
     
    Output
    For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.
     
    Sample Input
    1 10 1
    20 3 30
    4 0 0
     
    Sample Output
    Case 1: 2
    Case 2: 4
    Case 3: 5
     
    Source
     
    Recommend
    JGShining
     
    思路:数学
     
    代码:
    #include <stdio.h>
    #include <stdlib.h>
    double n,m,i,j;
    int
    sum;
    int
    d;
    int
    main()
    {

        int
    t ;
        double
    s1;
        int
    s2;
        int
    k;
        scanf("%d",&k);
        for
    (d = 1;d <= k;d ++)
        {

              t = 1;
        while
    (scanf("%lf%lf",&n,&m),n != 0||m != 0)
        {

            printf("Case %d: ",t);
            t ++;
            sum = 0;
            for
    (i = 1;i < n;i ++)
                for
    (j = i +1;j < n;j ++)
                {

                     s1 = (i * i + j * j + m) / (j * i); //printf("%lf ",s1);                  s2 = (int)s1;
                     if
    (s2 == s1)
                     sum ++;
                    }

                  printf("%d ",sum);
       
        }

        if
    (d != k)
            printf(" ");

      }
     
    }
  • 相关阅读:
    codeforces570D Tree Requests
    codeforces600E Lomsat gelral
    BZOJ2001 [Hnoi2010]City 城市建设
    BZOJ2565 最长双回文串
    BZOJ4031 [HEOI2015]小Z的房间
    BZOJ2467 [中山市选2010]生成树
    SPOJ104 HIGH
    爆零系列—补题A
    DP一直是自己的弱势 开始练滚动数组——HDOJ4502
    HDOJ4550 卡片游戏 随便销毁内存的代价就是wa//string类的一些用法
  • 原文地址:https://www.cnblogs.com/GODLIKEING/p/3286457.html
Copyright © 2011-2022 走看看