zoukankan      html  css  js  c++  java
  • HDU 1241 Oil Deposits

    Oil Deposits

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 8431    Accepted Submission(s): 4920

    Problem Description
    The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
     
    Input
    The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
     
    Output
    For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
     
    Sample Input
    1 1 
    *
    3 5
    *@*@*
    **@**
    *@*@*
    1 8
    @@****@*
    5 5
    ****@
    *@@*@
    *@**@
    @@@*@
    @@**@
    0 0
     
    Sample Output
    0
    1
    2
    2
     
    Source
     
    Recommend
    Eddy
     
    思路:DFS,太水了
     
    代码:
    #include <iostream>
    #include <cstdio>
    #include <stack>
    #include <cstring>
    using namespace std;
    int n,m;
    int a,b;
    int sum;
    struct Node
    {
        int x,y;
    };
    int move[8][2] = {1,0,-1,0,0,1,0,-1,1,1,-1,1,1,-1,-1,-1};
    int hash[110][110];
    char map[110][110];
    void DFS()
    {
        stack < Node > s;
        Node top;top.x = a;top.y = b;
        s.push(top);
        while(!s.empty())
        {
            Node temp = s.top();s.pop();
            //printf("%d %d is %d ",temp.x,temp.y,sum);
            for(int i = 0;i < 8;i ++)
            {
                int x = temp.x + move[i][0];int y = temp.y + move[i][1];
                if(!hash[x][y] && map[x][y] == '@' &&
                x >= 1 && x <= n && y <= m && y >= 1)
                {
                    hash[x][y] = 1;
                    Node xin;xin.x = x;xin.y = y;
                    s.push(xin);
                    //hash[x][y] = 0;
                }
            }
        }
        //sum ++;
    }
    void DDD()
    {
        DFS();
        sum ++;
    }
    int main()
    {
        while(scanf("%d%d",&n,&m),n != 0 && m != 0)
        {
            memset(hash,0,sizeof(hash));
            sum = 0;
            for(int i = 1;i <= n;i ++)
               for(int j = 1;j <= m;j ++)
               {
                 scanf(" %c",&map[i][j]);
               }
            for(int i = 1;i <= n;i ++)
               for(int j = 1;j <= m;j ++)
                    if(map[i][j] == '@' && hash[i][j] == 0)
                    {
                            hash[i][j] = 1;
                            a = i;b = j;
                            DDD();
                    }
            printf("%d ",sum);
        }
        return 0;
    }
           
           
     
  • 相关阅读:
    C#下实现ping功能
    Telnet Chat Daemon
    ADO.NET连接池
    很好使的MAIL CLASS
    实例看多态
    完整的TCP通信包实现
    使用C#进行点对点通讯和文件传输(通讯基类部分)(转)
    特洛伊木马服务器源代码(C#)
    [C#] 如何选择一个目录
    如何使用C#压缩文件及注意的问题!
  • 原文地址:https://www.cnblogs.com/GODLIKEING/p/3287806.html
Copyright © 2011-2022 走看看