zoukankan      html  css  js  c++  java
  • HDU 1240 Asteroids!

    Asteroids!

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 2789    Accepted Submission(s): 1863

    Problem Description
    You're in space. You want to get home. There are asteroids. You don't want to hit them.
     
    Input
    Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets.
    A single data set has 5 components:
    Start line - A single line, "START N", where 1 <= N <= 10.
    Slice list - A series of N slices. Each slice is an N x N matrix representing a horizontal slice through the asteroid field. Each position in the matrix will be one of two values:
    'O' - (the letter "oh") Empty space
    'X' - (upper-case) Asteroid present
    Starting Position - A single line, "A B C", denoting the <A,B,C> coordinates of your craft's starting position. The coordinate values will be integers separated by individual spaces.
    Target Position - A single line, "D E F", denoting the <D,E,F> coordinates of your target's position. The coordinate values will be integers separated by individual spaces.
    End line - A single line, "END"
    The origin of the coordinate system is <0,0,0>. Therefore, each component of each coordinate vector will be an integer between 0 and N-1, inclusive.
    The first coordinate in a set indicates the column. Left column = 0.
    The second coordinate in a set indicates the row. Top row = 0.
    The third coordinate in a set indicates the slice. First slice = 0.
    Both the Starting Position and the Target Position will be in empty space.
     
    Output
    For each data set, there will be exactly one output set, and there will be no blank lines separating output sets.
    A single output set consists of a single line. If a route exists, the line will be in the format "X Y", where X is the same as N from the corresponding input data set and Y is the least number of moves necessary to get your ship from the starting position to the target position. If there is no route from the starting position to the target position, the line will be "NO ROUTE" instead.
    A move can only be in one of the six basic directions: up, down, left, right, forward, back. Phrased more precisely, a move will either increment or decrement a single component of your current position vector by 1.
     
    Sample Input
    START 1
    O
    0 0 0
    0 0 0
    END
    START 3
    XXX
    XXX
    XXX
    OOO
    OOO
    OOO
    XXX
    XXX
    XXX
    0 0 1
    2 2 1
    END
    START 5
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    XXXXX
    XXXXX
    XXXXX
    XXXXX
    XXXXX
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    OOOOO
    0 0 0
    4 4 4
    END
     
    Sample Output
    1 0 3 4 NO ROUTE
     
    Source
     
    Recommend
    zf
     
     思路:好水
     
    代码:
    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <cstdlib>
    #include <algorithm>
    #include <queue>
    using namespace std;
    char str1[10];
    char str2[10];
    char map[12][12][12];
    int n;
    int start_x,start_y,start_z;
    int end_x,end_y,end_z;
    int the_last_step;
    int hash[12][12][12];
    int flag;
    struct Node
    {
        int x;
        int y;
        int z;
        int step;
    };
    int move[6][3] = {1,0,0,-1,0,0,0,1,0,0,-1,0,0,0,1,0,0,-1};
    void BFS()
    {
        queue <Node> q;
        Node top;
        top.x = start_x;top.y = start_y;top.z = start_z;top.step = 0;
        q.push(top);
        while(!q.empty())
        {
            Node temp = q.front();q.pop();
            if(temp.x == end_x && temp.y == end_y && temp.z == end_z)
            {
                the_last_step = temp.step;
                return ;
            }
            for(int i = 0;i < 6;i ++)
            {
                int x = temp.x + move[i][0];
                int y = temp.y + move[i][1];
                int z = temp.z + move[i][2];
                int step = temp.step + 1;
                if(hash[x][y][z] == 0)
                {
                    if(x >= 0 && x < n && y >= 0 && y < n && z >= 0 && z < n
                    && map[x][y][z] == 'O')
                    {
                        Node xin;
                        xin.x = x;xin.y = y;xin.z = z;xin.step = step;
                        hash[x][y][z] = 1;
                        q.push(xin);
                    }
                }
            }
        }
        return ;
    }
    int main()
    {
        while(cin >> str1 >> n)
        {
            memset(hash,0,sizeof(hash));
            memset(map,0,sizeof(map));
            for(int i = 0;i < n;i ++)
               for(int j = 0;j < n;j ++)
                  for(int k = 0;k < n;k ++)
                        cin >> map[k][j][i];
            scanf("%d%d%d",&start_x,&start_y,&start_z);
            hash[start_x][start_y][start_z] = 1;
            scanf("%d%d%d",&end_x,&end_y,&end_z);
            cin >> str2;
            the_last_step = -1;
            BFS();
            if(the_last_step == -1)
                 printf("NO ROUTE ");
            else
                 printf("%d %d ",n,the_last_step);
        }
        return 0;
    }
  • 相关阅读:
    JSON对象和字符串之间的相互转换
    Loadrunner 运行场景时:missing newline in XXX.dat 错误解决
    linux grep详解
    Object 保存到文件中
    'libxml/tree.h' file not found
    具有相同值的不同字符串常量在内存中是分开存储的
    为右键添加快速进入CMD的选项,Win7更简单
    iOS KVO & KVC
    南阳数乌龟——递归超时
    LibSVM笔记系列(3)——初学移植libsvm的C/C++版本
  • 原文地址:https://www.cnblogs.com/GODLIKEING/p/3346493.html
Copyright © 2011-2022 走看看