zoukankan      html  css  js  c++  java
  • nyoj 103-A+B Problem II (python 大数相加)

    103-A+B Problem II


    内存限制:64MB 时间限制:3000ms 特判: No
    通过数:10 提交数:45 难度:3

    题目描述:

    I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

    A,B must be positive.

    输入描述:

    The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

    输出描述:

    For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. 

    样例输入:

    2
    1 2
    112233445566778899 998877665544332211

    样例输出:

    Case 1:
    1 + 2 = 3
    Case 2:
    112233445566778899 + 998877665544332211 = 1111111111111111110

    python AC:

    n = int(input())
    for i in range(1, n + 1):  # 默认从0开始,后面那个数为不包括的数
        a, b = map(int, input().split())  # 实现两个值在同一行输入
        print("Case %d:" % i)
        print("%d + %d = %d" % (a, b, a + b))
        i += 1

    致谢

  • 相关阅读:
    CF754A
    快速幂模板
    循环-21. 求交错序列前N项和(15)
    循环-20. 猜数字游戏(15)
    循环-19. 币值转换
    循环-18. 龟兔赛跑(20)
    循环-17. 简单计算器(20)
    循环-11. 水仙花数(20)
    IO 分支 循环
    check list
  • 原文地址:https://www.cnblogs.com/GetcharZp/p/9328517.html
Copyright © 2011-2022 走看看