zoukankan      html  css  js  c++  java
  • POJ:3111-K Best

    K Best

    Time Limit: 8000MS Memory Limit: 65536K
    Total Submissions: 12985 Accepted: 3324
    Case Time Limit: 2000MS Special Judge

    Description

    Demy has n jewels. Each of her jewels has some value vi and weight wi.

    Since her husband John got broke after recent financial crises, Demy has decided to sell some jewels. She has decided that she would keep k best jewels for herself. She decided to keep such jewels that their specific value is as large as possible. That is, denote the specific value of some set of jewels S = {i1, i2, …, ik} as sum(vi)/sum(wi)

    .

    Demy would like to select such k jewels that their specific value is maximal possible. Help her to do so.

    Input

    The first line of the input file contains n — the number of jewels Demy got, and k — the number of jewels she would like to keep (1 ≤ k ≤ n ≤ 100 000).

    The following n lines contain two integer numbers each — vi and wi (0 ≤ vi ≤ 106, 1 ≤ wi ≤ 106, both the sum of all vi and the sum of all wi do not exceed 107).

    Output

    Output k numbers — the numbers of jewels Demy must keep. If there are several solutions, output any one.

    Sample Input

    3 2
    1 1
    1 2
    1 3

    Sample Output

    1 2


    解题心得:

    1. 还是一个二分平均值的问题,不懂得可以去看看挑战程序设计上面关于二分的推导。

    #include <algorithm>
    #include <stdio.h>
    using namespace std;
    const int maxn = 1e6+100;
    struct Jewels {
        int va,w,num;
        double c;
    }jew[maxn];
    
    int n,k;
    
    void init() {
        scanf("%d%d",&n,&k);
        for(int i=1;i<=n;i++) {
            scanf("%d%d",&jew[i].va,&jew[i].w);
            jew[i].num = i;
        }
    }
    
    bool cmp(Jewels a, Jewels b) {
        return a.c > b.c;
    }
    
    bool checke(double ave) {
        double sum = 0;
        for(int i=1;i<=n;i++) {
            jew[i].c = (double)jew[i].va - (double)jew[i].w*ave;
        }
        sort(jew+1,jew+n+1,cmp);
        for(int i=1;i<=k;i++) {
            sum += jew[i].c;
        }
        return sum >= 0;
    }
    
    void binary_search() {
        double l,r;
        r = 1000000000.0,l = 0;
        for(int i=0;i<50;i++) {
            double mid = (l + r) / 2;
            if(checke(mid))
                l = mid;
            else
                r = mid;
        }
    }
    
    int main() {
        init();
        binary_search();
        for(int i=1;i<=k;i++)
            printf("%d ",jew[i].num);
        return 0;
    }
  • 相关阅读:
    随手乱记
    对拍程序
    生命游戏
    Command Operating System by cdsidi(ComSys) 0.2.x版本陆续更新
    C语言<stdio.h>的rename函数——重命名文件、更改文件路径或更改目录名
    C++ 类中的static 成员函数
    Command Operating System by cdsidi(ComSys) 0.1.x版本陆续更新
    Command Operating System by cdsidi (ComSys)首次发布(版本0.1.2)
    区间dp之 "石子合并"系列(未完结)
    C/C++快读(快速读入)有多——安全AC
  • 原文地址:https://www.cnblogs.com/GoldenFingers/p/9107121.html
Copyright © 2011-2022 走看看