zoukankan      html  css  js  c++  java
  • POJ:2393-Yogurt factory

    传送门:poj.org/problem?id=2393

    Yogurt factory

    Time Limit: 1000MS Memory Limit: 65536K
    Total Submissions: 13073 Accepted: 6577

    Description

    The cows have purchased a yogurt factory that makes world-famous Yucky Yogurt. Over the next N (1 <= N <= 10,000) weeks, the price of milk and labor will fluctuate weekly such that it will cost the company C_i (1 <= C_i <= 5,000) cents to produce one unit of yogurt in week i. Yucky’s factory, being well-designed, can produce arbitrarily many units of yogurt each week.

    Yucky Yogurt owns a warehouse that can store unused yogurt at a constant fee of S (1 <= S <= 100) cents per unit of yogurt per week. Fortuitously, yogurt does not spoil. Yucky Yogurt’s warehouse is enormous, so it can hold arbitrarily many units of yogurt.

    Yucky wants to find a way to make weekly deliveries of Y_i (0 <= Y_i <= 10,000) units of yogurt to its clientele (Y_i is the delivery quantity in week i). Help Yucky minimize its costs over the entire N-week period. Yogurt produced in week i, as well as any yogurt already in storage, can be used to meet Yucky’s demand for that week.

    Input

    • Line 1: Two space-separated integers, N and S.

    • Lines 2..N+1: Line i+1 contains two space-separated integers: C_i and Y_i.

    Output

    • Line 1: Line 1 contains a single integer: the minimum total cost to satisfy the yogurt schedule. Note that the total might be too large for a 32-bit integer.

    Sample Input

    4 5
    88 200
    89 400
    97 300
    91 500

    Sample Output

    126900

    Hint

    OUTPUT DETAILS:
    In week 1, produce 200 units of yogurt and deliver all of it. In week 2, produce 700 units: deliver 400 units while storing 300 units. In week 3, deliver the 300 units that were stored. In week 4, produce and deliver 500 units.


    解题心得:

    1. 题意就是一家工厂,每天生产一单位牛奶的单价是s,每天必须交货y单位的牛奶,如果储存牛奶,储存的牛奶的单价每天会上涨c。问如果按要求提供牛奶,最少花费是多少。
    2. 按照贪心,可以假设将每天的牛奶都储存起来了,但是暂时不算储存的钱,只有每次取最小花费牛奶的时候算钱。但是怎么维护所有牛奶储存起来的信息呢?其实不用维护所有的信息,只要维护最小价格的那个牛奶就行了,因为你每次都是只取最小的,而所有的储存牛奶都是每次涨c元最小的值只会在新的一天的时候变换,所以直接维护最小值,每次用最小值来进行计算。

    #include <stdio.h>
    #include <algorithm>
    using namespace std;
    typedef long long ll;
    int main() {
        ll n,s,Min = 0x7f7f7f7f;
        ll ans = 0;
        scanf("%lld%lld",&n,&s);
        for(int i=0;i<n;i++) {
            ll c,y;
            scanf("%lld%lld",&c,&y);
            Min += s;
            if(c < Min)
                Min = c;
            ans += y*Min;
        }
        printf("%lld",ans);
        return 0;
    }
  • 相关阅读:
    设计模式——代理模式
    设计模式——建造者模式
    设计模式——模板方法
    springboot+mybatis项目自动生成
    【小坑】java下载excel文件
    设计模式——工厂方法模式 和 抽象工厂模式
    设计模式——单例模式
    容易忽略的递归当中的return
    Android 4.0以后正确的获取外部sd卡存储目录
    Android 串口设置校验位、速率、停止位等参数
  • 原文地址:https://www.cnblogs.com/GoldenFingers/p/9107156.html
Copyright © 2011-2022 走看看