zoukankan      html  css  js  c++  java
  • POJ:2109-Power of Cryptography(关于double的误差)

    Power of Cryptography

    Time Limit: 1000MS Memory Limit: 30000K

    Description

    Current work in cryptography involves (among other things) large prime numbers and computing powers of numbers among these primes. Work in this area has resulted in the practical use of results from number theory and other branches of mathematics once considered to be only of theoretical interest.
    This problem involves the efficient computation of integer roots of numbers.
    Given an integer n>=1 and an integer p>= 1 you have to write a program that determines the n th positive root of p. In this problem, given such integers n and p, p will always be of the form k to the nth. power, for an integer k (this integer is what your program must find).

    Input

    The input consists of a sequence of integer pairs n and p with each integer on a line by itself. For all such pairs 1<=n<= 200, 1<=p<10101 and there exists an integer k, 1<=k<=109 such that kn = p.

    Output

    For each integer pair n and p the value k should be printed, i.e., the number k such that k n =p.

    Sample Input

    2 16
    3 27
    7 4357186184021382204544

    Sample Output

    4
    3
    1234


    • 刚看到的时候还是想用大数硬怼,但是明显不可能啊。看了一下网上别人的代码,发现代码很简单。但是关于double的误差问题都没怎么说清楚,想关注double详情的可以看看大神的分析:http://blog.csdn.net/synapse7/article/details/11672691

    #include<stdio.h>
    #include<iostream>
    #include<math.h>
    using namespace std;
    int main()
    {
        double a,b;
        while(cin>>a>>b)
        {
            cout<<pow(b,1.0/a)<<endl;
        }
        return 0;
    }
  • 相关阅读:
    75. 颜色分类
    排序链表
    两个数组的交集
    242. 有效的字母异位词
    排序优化
    622.设计循环队列
    比较含退格的字符串
    682.棒球比赛
    496.下一个更大的元素I
    线性排序算法
  • 原文地址:https://www.cnblogs.com/GoldenFingers/p/9107239.html
Copyright © 2011-2022 走看看