zoukankan      html  css  js  c++  java
  • Nested Dolls 贪心 + dp

    G: Nested Dolls

    Time Limit: 1 Sec     Memory Limit: 128 Mb     Submitted: 99     Solved: 19    


    Description

    Dilworth is the world’s most prominent collector of Russian nested dolls: he literally has thousands of them! You know, the wooden hollow dolls of different sizes of which the smallest doll is contained in the second smallest, and this doll is in turn contained in the next one and so forth. One day he wonders if there is another way of nesting them so he will end up with fewer nested dolls? After all, that would make his collection even more magnificent! He unpacks each nested doll and measures the width and height of each contained doll. A doll with width w1 and height h1 will fit in another doll of width w2 and height h2 if and only if w1 < w2 and h1 < h2. Can you help him calculate the smallest number of nested dolls possible to assemble from his massive list of measurements?

    Input

    On the first line of input is a single positive integer 1<=t<=20 specifying the number of test cases to follow. Each test case begins with a positive integer 1<=m<=20000 on a line of itself telling the number of dolls in the test case. Next follow 2m positive integers w1, h1,w2, h2, . . . ,wm, hm, where wi is the width and hi is the height of doll number i. 1<=wi, hi<=10000 for all i.

    Output

    For each test case there should be one line of output containing the minimum number of nested dolls possible.

    Sample Input

    4
    3
    20 30 40 50 30 40
    4
    20 30 10 10 30 20 40 50
    3
    10 30 20 20 30 10
    4
    10 10 20 30 40 50 39 51

    Sample Output

    1
    2
    3
    2

    题意:有m个嵌套娃娃,如果娃娃的高h和宽w都小于另一个娃娃,那么就能嵌套成为一个娃娃。
       问最少会剩下多少个娃娃。



    很容易想到把娃娃按照宽度从大到小,高度从低到高进行排序,然后只要单独去分析高就可以找出最后有多少娃娃了;

    dp保存的是每次能嵌套的最后一个娃娃的高度,最后找一遍一共有多少个最后一个娃娃,就行了。


    #include "cstdio"
    #include "cstring"
    #include "iostream"
    #include "algorithm"
    #include "cmath"
    using namespace std;
    #define memset(x,y) memset(x,y,sizeof(x))
    
    
    struct box
    {
        int h,w;
    } B[20005],dp[20005];;
    
    
    bool cmp(box a,box b)
    {
        if(a.w==b.w)return a.h<b.h;
        return a.w >b.w;
    }
    int main()
    {
        int T,n;
        cin>>T;
        while(T--)
        {
            int ans=0;
            cin>>n;
            memset(dp,0x3f);
            for(int i=0; i<n; i++)
            {
                scanf("%d%d",&B[i].w,&B[i].h);
            }
            sort(B,B+n,cmp);
            int tem=dp[0].h;
            for(int i=0;i<n;i++){
                int j=0;
                while(dp[j].h<=B[i].h){
                    j++;
                }
                    dp[j].h=B[i].h;
            }
            for(int i=0;i<n;i++){
                if(dp[i].h!=tem)ans++;
            }
            cout <<ans<<endl;
        }
        return 0;
    }
    

      

  • 相关阅读:
    [CLYZ2017]day10
    标签
    FJOI2017一试滚粗
    [学习笔记]一些求gcd的方法的证明
    WC2017有感
    [学习笔记]splay
    [CLYZ2017]day9
    [CLYZ2017]day6
    转:Asp.net模板引擎技术(html)
    精华:ASP.NET开发网站程序安全解决方案(防注入等)
  • 原文地址:https://www.cnblogs.com/HDMaxfun/p/6752726.html
Copyright © 2011-2022 走看看