zoukankan      html  css  js  c++  java
  • POJ 1837 Balance【DP】

    Description

    Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance. 
    It orders two arms of negligible weight and each arm's length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights. 
    Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced. 

    Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device. 
    It is guaranteed that will exist at least one solution for each test case at the evaluation. 

    Input

    The input has the following structure: 
    • the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20); 
    • the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: '-' for the left arm and '+' for the right arm); 
    • on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights' values. 

    Output

    The output contains the number M representing the number of possibilities to poise the balance.

    Sample Input

    2 4	
    -2 3 
    3 4 5 8
    

    Sample Output

    2

    题意:给出c个坐标轴的位置,g个砝码,有多少种情况放置全部的砝码使得平衡。

    思路:当砝码i放上时,只与前一个状态有关。平衡度j,当j=0,说明左右平衡;当j>0, 天平倾向右边;由于距离c[i]的范围是-15~15,钩码重量的范围是1~25,钩码数量最大是20

    因此最极端的平衡度是所有物体都挂在最远端,因此平衡度最大值为j=15*20*25=7500。原则上就应该有dp[ 1~20 ][-7500 ~ 7500 ]。因此为了不让下标出现负数,做一个处理,使使得数组开为 dp[1~20][0~15000],则当j=7500时天枰为平衡状态。

    Dp[i][j]表示在挂满前i个钩码时,平衡度为j的挂法的数量。

    dp[i][ j+ w[i]*c[k] ] = dp[i-1][j] = num….若得到状态转移方程得到的 状态方程为dp[i][j] =∑(dp[i - 1][j - c[i] * w[i]]) 也必须转化为第一条方程,这是为了避免下标出现负数

    代码如下:

    #include<stdio.h>
    #include<string.h>
    int dp[22][15005]; 
    int main()
    {
    	int i, j, k, m, n;
    	int p[22], g[22]; 
    	while(scanf("%d%d", &m, &n)!=EOF)
    	{
    		for(i=1; i<=m; i++)
    			scanf("%d", &p[i]);
    		for(i=1; i<=n; i++)
    			scanf("%d", &g[i]);
    		memset(dp, 0, sizeof(dp));
    		dp[0][7500]=1; 
    		for(i=1; i<=n; i++)
    			for(j=-7500; j<=7500; j++)
    			{
    				if(dp[i-1][j+7500]!=0) 
    					for(k=1; k<=m; k++)
    						//dp[i][j+7500]+=dp[i-1][7500+j-p[k]*g[i-1]];//避免下表出现负数 
    						dp[i][j+7500+p[k]*g[i]]+=dp[i-1][j+7500]; 
    			}
    		printf("%d\n", dp[n][7500]);
    	}
    	return 0;
    }
  • 相关阅读:
    Linux九阴真经之催心掌残卷5(正则表达式)
    Linux九阴真经之催心掌残卷4(grep文本处理 )
    Linux九阴真经之催心掌残卷3
    Linux九阴真经之催心掌残卷2
    0.1.kubeadm快速部署kubernetes
    0.2.kubeadm搭建kubernetes高可用集群(CentOS)
    Nginx——模块(1)
    Nginx——主配置段
    Nginx——安装
    Nginx——I/O模型
  • 原文地址:https://www.cnblogs.com/Hilda/p/2616880.html
Copyright © 2011-2022 走看看