zoukankan      html  css  js  c++  java
  • POJ 2063 Investment【完全背包】

    Description

    John never knew he had a grand-uncle, until he received the notary's letter. He learned that his late grand-uncle had gathered a lot of money, somewhere in South-America, and that John was the only inheritor.
    John did not need that much money for the moment. But he realized that it would be a good idea to store this capital in a safe place, and have it grow until he decided to retire. The bank convinced him that a certain kind of bond was interesting for him.
    This kind of bond has a fixed value, and gives a fixed amount of yearly interest, payed to the owner at the end of each year. The bond has no fixed term. Bonds are available in different sizes. The larger ones usually give a better interest. Soon John realized that the optimal set of bonds to buy was not trivial to figure out. Moreover, after a few years his capital would have grown, and the schedule had to be re-evaluated.
    Assume the following bonds are available:
    Value Annual
    interest
    4000
    3000
    400
    250

    With a capital of e10 000 one could buy two bonds of $4 000, giving a yearly interest of $800. Buying two bonds of $3 000, and one of $4 000 is a better idea, as it gives a yearly interest of $900. After two years the capital has grown to $11 800, and it makes sense to sell a $3 000 one and buy a $4 000 one, so the annual interest grows to $1 050. This is where this story grows unlikely: the bank does not charge for buying and selling bonds. Next year the total sum is $12 850, which allows for three times $4 000, giving a yearly interest of $1 200.
    Here is your problem: given an amount to begin with, a number of years, and a set of bonds with their values and interests, find out how big the amount may grow in the given period, using the best schedule for buying and selling bonds.

    Input

    The first line contains a single positive integer N which is the number of test cases. The test cases follow.
    The first line of a test case contains two positive integers: the amount to start with (at most $1 000 000), and the number of years the capital may grow (at most 40).
    The following line contains a single number: the number d (1 <= d <= 10) of available bonds.
    The next d lines each contain the description of a bond. The description of a bond consists of two positive integers: the value of the bond, and the yearly interest for that bond. The value of a bond is always a multiple of $1 000. The interest of a bond is never more than 10% of its value.

    Output

    For each test case, output – on a separate line – the capital at the end of the period, after an optimal schedule of buying and selling.

    Sample Input

    1
    10000 4
    2
    4000 400
    3000 250

    Sample Output

    14050

    思路

    这题是一道简单的完全背包题(于0-1背包就是第二个for循环倒过来就行了)

    主要目的就是:考虑选入第i个物品时,依据是已经选入第i个物品n个(n=0, 1,2,..)

    还要注意一点:The value of a bond is always a multiple of $1 000;

    因此避免超内存可使bond/1000进行计算;

    源码

    #include<stdio.h>

    #include<string.h>

    #include<iostream>

    using namespace std;

    int bag[50000];

    int main()

    {

           int T, start, year, d, i, j, k;

           int value[20], interest[20];

           scanf("%d", &T);

           while(T--)

           {

                  scanf("%d%d", &start, &year);

                  scanf("%d", &d);

                  for(i=1; i<=d; i++)

                         scanf("%d%d", &value[i], &interest[i]);

                  for(i=1; i<=d; i++)

                         value[i]/=1000;

                  int finallmoney=start;

                  for(k=1; k<=year; k++)

                  {

                         start/=1000;

                         memset(bag, 0, sizeof(bag));

                         for(i=1; i<=d; i++)

                                for(j=value[i]; j<=start; j++)

                                       bag[j]=max(bag[j], bag[j-value[i]]+interest[i]);

                         finallmoney+=bag[start];

                         start=finallmoney;

                  }

                  printf("%d\n", finallmoney);

           }

    }

  • 相关阅读:
    Educational Codeforces Round 80 (Rated for Div. 2)
    寒假集训
    HDU-4609 3-idiots
    部分分式展开法
    线性同余方程组
    爬取哔哩哔哩python搜索结果
    数据可视化练习题
    python正则表达式
    git的安装和基础知识
    python学习计划
  • 原文地址:https://www.cnblogs.com/Hilda/p/2616912.html
Copyright © 2011-2022 走看看