zoukankan      html  css  js  c++  java
  • HDU 1069 Monkey and Banana【DP】

    Problem Description
    A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

    The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

    They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

    Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.
     
    Input
    The input file will contain one or more test cases. The first line of each test case contains an integer n,
    representing the number of different blocks in the following data set. The maximum value for n is 30.
    Each of the next n lines contains three integers representing the values xi, yi and zi.
    Input is terminated by a value of zero (0) for n.
     
    Output
    For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
     
    Sample Input
    1
    10 20 30
    2
    6 8 10
    5 5 5
    7
    1 1 1
    2 2 2
    3 3 3
    4 4 4
    5 5 5
    6 6 6
    7 7 7
    5
    31 41 59
    26 53 58
    97 93 23
    84 62 64
    33 83 27
    0
     
    Sample Output
    Case 1: maximum height = 40
    Case 2: maximum height = 21
    Case 3: maximum height = 28
    Case 4: maximum height = 342

    思路

    题目大意:(有必要说一下,因为我就没看懂)。给出n种不同的砖块,垒成高度尽可能的大,但是要求下面的长和宽大于上面的长和宽。而且每种类型的砖块数量是任意的,因此每种砖块可以当做6块砖块用。

    思路:转化为最长下降子序列。

    源码

    #include<stdio.h>

    #include<string.h>

    #include<iostream>

    #include<algorithm>

    using namespace std;

    struct block

    {

        int x, y, z;

    };

    int cmp(block xx, block yy)

    {

        if(xx.x!=yy.x)

            return xx.x>yy.x;

        else

            return xx.y>yy.y;

    }

    int main()

    {

        int n, i, j, a, b, c, T=0;

        while(scanf("%d", &n)==1&&n)

        {

            block B[200];

            T++;

            printf("Case %d: maximum height = ", T);

            for(i=0; i<n; i++)

            {

                int t=i*6;

                scanf("%d%d%d", &a, &b, &c);

                B[t].x=a, B[t].y=b, B[t].z=c;

                B[t+1].x=a, B[t+1].y=c, B[t+1].z=b;

                B[t+2].x=b, B[t+2].y=a, B[t+2].z=c;

                B[t+3].x=b, B[t+3].y=c, B[t+3].z=a;

                B[t+4].x=c, B[t+4].y=b, B[t+4].z=a;

                B[t+5].x=c, B[t+5].y=a, B[t+5].z=b;

            }

            sort(B, B+6*n, cmp);

            int f[200];

            memset(f, 0, sizeof(f));

            int maxnum=0;

            for(i=0; i<6*n; i++)

            {

                //printf("%d %d %d\n", B[i].x, B[i].y, B[i].z);

                f[i]=B[i].z;

                for(j=0; j<i; j++)

                {

                    if(B[i].x<B[j].x&&B[i].y<B[j].y&&f[j]+B[i].z>f[i])

                        f[i]=f[j]+B[i].z;

                }

                maxnum=max(maxnum, f[i]);

            }

            printf("%d\n", maxnum);

        }

    }

  • 相关阅读:
    [转]Cordova + Ionic in Visual Studio
    [转]Getting Start With Node.JS Tools For Visual Studio
    TypeScript
    [转]NPOI TestFunctionRegistry.cs
    [转]Cordova android框架详解
    [转]POI : How to Create and Use User Defined Functions
    [转]用NPOI操作EXCEL--通过NPOI获得公式的返回值
    [转]Formatting the detail section to display multiple columns (水晶报表 rpt 一页多列)
    [转]Creating Mailing Labels in SQL Server Reporting Services (rdlc 数据1页 2竖排 显示)
    [转]Tetris(俄罗斯方块) in jQuery/JavaScript!
  • 原文地址:https://www.cnblogs.com/Hilda/p/2617263.html
Copyright © 2011-2022 走看看