zoukankan      html  css  js  c++  java
  • POJ 2236 Wireless Network【裸并查集+计算几何】

    Description

    An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. 

    In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations. 

    Input

    The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 
    1. "O p" (1 <= p <= N), which means repairing computer p. 
    2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. 

    The input will not exceed 300000 lines. 

    Output

    For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

    Sample Input

    4 1
    0 1
    0 2
    0 3
    0 4
    O 1
    O 2
    O 4
    S 1 4
    O 3
    S 1 4
    

    Sample Output

    FAIL
    SUCCESS

    思路:当给出已经修的点,进行标记。枚举所有点,如满足距离小于d而且是修过的进行合并。
    代码如下:
    View Code
    #include<stdio.h>
    #include<string.h>
    #include<iostream>
    using namespace std; 
    struct point
    {
        int x, y;
    }; 
    int father[1005], visit[1005];
    int find(int x)
    {
        return x==father[x]?x:father[x]=find(father[x]);
    } 
    int main()
    {
        int n, d, i, a, b;
        scanf("%d%d", &n, &d);
        char ch; 
        point p[1005]; 
        for(i=0; i<=n; i++)
            father[i]=i;
        for(i=1; i<=n; i++)
            scanf("%d%d", &p[i].x, &p[i].y); 
        getchar(); 
        memset(visit, 0, sizeof(visit)); 
        while(scanf("%c", &ch)!=EOF)
        {
            if(ch=='O')
            {
                scanf("%d", &a);
                visit[a]=1; 
                for(i=1; i<=n; i++)
                {
                    if((p[a].x-p[i].x)*(p[a].x-p[i].x)+(p[a].y-p[i].y)*(p[a].y-p[i].y)<=d*d&&visit[i]==1)
                    {
                        int xx=find(a), yy=find(i);
                        if(xx<yy)    father[yy]=xx;
                        else    father[xx]=yy;
                    }
                }
            }
            else
            {
                scanf("%d%d", &a, &b);
                int xx=find(a), yy=find(b);
                if(xx==yy)     printf("SUCCESS\n");
                else    printf("FAIL\n");
            }
            getchar(); 
        }
    }        
  • 相关阅读:
    迭代器生成器
    eval()
    【剑指offer】调整数组数字位置
    【剑指offer】二进制中1的个数
    【剑指offer】斐波那契数列非递归求解第N项
    【剑指offer】两个栈实现队列
    【剑指offer】逆序输出链表
    【剑指offer】字符串替换
    【剑指offer】规则二维数组查找
    Java转型
  • 原文地址:https://www.cnblogs.com/Hilda/p/2626583.html
Copyright © 2011-2022 走看看