zoukankan      html  css  js  c++  java
  • POJ 3370 Halloween treats【抽屉原理】

    题目链接:http://poj.org/problem?id=3370

    Description

    Every year there is the same problem at Halloween: Each neighbour is only willing to give a certain total number of sweets on that day, no matter how many children call on him, so it may happen that a child will get nothing if it is too late. To avoid conflicts, the children have decided they will put all sweets together and then divide them evenly among themselves. From last year's experience of Halloween they know how many sweets they get from each neighbour. Since they care more about justice than about the number of sweets they get, they want to select a subset of the neighbours to visit, so that in sharing every child receives the same number of sweets. They will not be satisfied if they have any sweets left which cannot be divided.

    Your job is to help the children and present a solution.

    Input

    The input contains several test cases.
    The first line of each test case contains two integers c and n (1 ≤ c ≤ n ≤ 100000), the number of children and the number of neighbours, respectively. The next line contains n space separated integers a1 , ... , an (1 ≤ ai ≤ 100000 ), where ai represents the number of sweets the children get if they visit neighbour i.

    The last test case is followed by two zeros.

    Output

    For each test case output one line with the indices of the neighbours the children should select (here, index i corresponds to neighbour i who gives a total number of ai sweets). If there is no solution where each child gets at least one sweet print "no sweets" instead. Note that if there are several solutions where each child gets at least one sweet, you may print any of them.

    Sample Input

    4 5
    1 2 3 7 5
    3 6
    7 11 2 5 13 17
    0 0

    Sample Output

    3 5
    2 3 4

    题目大意:n个小朋友,拜访m家,每家会得到a[i]块糖,使得得到的糖数总和是n的倍数,输出拜访谁家。(这里未要求连续)
    解题思路: 与POJ 2356几乎一样,n<=m, 不用考虑是否是连续的和。由于抽屉原理,最终都会至少有两个模值相同的数在一个抽屉中,不影响结果。
    也就是说这题不存在无解的情况

    代码如下:

    View Code
    #include<stdio.h>
    #include<string.h>
    int sum[100003], pla[100003];
    int main()
    {
        int i, n, pp, j, m, a;
        while(scanf("%d%d", &n, &m)!=EOF)
        {
            if(n==0&&m==0) break;
            sum[0]=0, pp=0;
            memset(pla, 0, sizeof(pla));
            for(i=1; i<=m; i++)
            {
                scanf("%d", &a);
                sum[i]=(sum[i-1]+a)%n;
                if(sum[i]==0)
                    pp=i;
            }
            if(pp!=0)
            {
                for(i=1; i<pp; i++)
                    printf("%d ", i);
                printf("%d\n", pp);  
            }
            else
            {
                for(i=1; i<=n; i++)
                {
                    if(pla[sum[i]]==0)
                        pla[sum[i]]=i;
                    else
                    {
                        for(j=pla[sum[i]]+1; j<i; j++)
                        {
                            printf("%d ", j);
                        }
                        printf("%d\n", i);
                        break;
                    }
                }
            }
        }
        return 0;
    } 
  • 相关阅读:
    大数据量分表时 两个表查询比较快的方式
    开启SQL Server执行占用时间显示和逻辑读取次数显示
    【转】SQL Server海量数据库的索引、查询优化及分页算法
    Exchange无法发送邮件 未找到匹配的连接器来路由外部收件人解决办法
    HTML介绍&常用的标签
    关于HTML文件、JS文件、CSS文件
    python命名空间和作用域
    pymysql
    存储过程、视图、触发器、函数
    多表查询
  • 原文地址:https://www.cnblogs.com/Hilda/p/2948610.html
Copyright © 2011-2022 走看看