zoukankan      html  css  js  c++  java
  • OpenJudge Bailian 1088 滑雪 DFS

    滑雪
    Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
     

    Description

    Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激。可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你。Michael想知道载一个区域中最长的滑坡。区域由一个二维数组给出。数组的每个数字代表点的高度。下面是一个例子 
     1  2  3  4 5
    16 17 18 19 6
    15 24 25 20 7
    14 23 22 21 8
    13 12 11 10 9

    一个人可以从某个点滑向上下左右相邻四个点之一,当且仅当高度减小。在上面的例子中,一条可滑行的滑坡为24-17-16-1。当然25-24-23-...-3-2-1更长。事实上,这是最长的一条。

    Input

    输入的第一行表示区域的行数R和列数C(1 <= R,C <= 100)。下面是R行,每行有C个整数,代表高度h,0<=h<=10000。

    Output

    输出最长区域的长度。

    Sample Input

    5 5
    1 2 3 4 5
    16 17 18 19 6
    15 24 25 20 7
    14 23 22 21 8
    13 12 11 10 9
    

    Sample Output

    25


    记忆化dfs
    #include <iostream>
    #include <cstring>
    #include <cstdio>
    #include <algorithm>
    #include <queue>
    #include <vector>
    #include <iomanip>
    #include <math.h>
    #include <map>
    using namespace std;
    #define FIN     freopen("input.txt","r",stdin);
    #define FOUT    freopen("output.txt","w",stdout);
    #define INF     0x3f3f3f3f
    #define INFLL   0x3f3f3f3f3f3f3f
    #define lson    l,m,rt<<1
    #define rson    m+1,r,rt<<1|1
    typedef long long LL;
    typedef pair<int,int> PII;
    
    const int MX = 1e2 + 5;
    
    int mp[MX][MX];
    int dp[MX][MX];
    int n, m;
    int to[4][2] = {1, 0, -1, 0, 0, 1, 0, -1};
    
    bool check(int x, int y) {
        return x >= 1 && x <= n && y >= 1 && y <= m;
    }
    
    int dfs(int x, int y) {
        int ans = 0;
        if(dp[x][y])  return dp[x][y];
        for(int i = 0; i < 4; i++) {
            int xx = x + to[i][0];
            int yy = y + to[i][1];
            if(!check(xx, yy) || mp[xx][yy] >= mp[x][y])  continue;
            ans = max(ans, dfs(xx, yy));
        }
        dp[x][y] = ans + 1;
        return dp[x][y];
    }
    
    int main()
    {
        //FIN
        while(cin >> n >> m) {
            for(int i = 1; i <= n; i++)
                for(int j = 1; j <= m; j++)
                    cin >> mp[i][j];
    
            memset(dp, 0, sizeof(dp));
    
            int ans = 0;
    
            for(int i = 1; i <= n; i++) {
                for(int j = 1; j <= m; j++) {
                    ans = max(ans, dfs(i, j));
                }
            }
    
    //        for(int i = 1; i <= n; i++) {
    //            for(int j = 1; j <= m; j++) {
    //                printf("%4d", dp[i][j]);
    //                if(j == m)  cout << endl;
    //            }
    //
    //        }
    
            cout << ans << endl;
        }
    
        return 0;
    }
    

      




  • 相关阅读:
    c++,模板函数的定义和使用【初探】
    c++,内联成员函数
    C++,对象成员的访问
    c++,public/protected/private权限修饰符
    c++,static 静态成员变量 / 静态成员函数
    C++,对象的 =赋值 以及 复制构造函数赋值
    Android 的提权(root)原理【转】
    高通LCD的pwm背光驱动
    IP地址的分类——a,b,c 类是如何划分的【转】
    Android分区
  • 原文地址:https://www.cnblogs.com/Hyouka/p/5828722.html
Copyright © 2011-2022 走看看