zoukankan      html  css  js  c++  java
  • AC日记——[USACO08DEC]干草出售Hay For Sale 洛谷 P2925

    题目描述

    Farmer John suffered a terrible loss when giant Australian cockroaches ate the entirety of his hay inventory, leaving him with nothing to feed the cows. He hitched up his wagon with capacity C (1 <= C <= 50,000) cubic units and sauntered over to Farmer Don's to get some hay before the cows miss a meal.

    Farmer Don had a wide variety of H (1 <= H <= 5,000) hay bales for sale, each with its own volume (1 <= V_i <= C). Bales of hay, you know, are somewhat flexible and can be jammed into the oddest of spaces in a wagon.

    FJ carefully evaluates the volumes so that he can figure out the largest amount of hay he can purchase for his cows.

    Given the volume constraint and a list of bales to buy, what is the greatest volume of hay FJ can purchase? He can't purchase partial bales, of course. Each input line (after the first) lists a single bale FJ can buy.

    约翰遭受了重大的损失:蟑螂吃掉了他所有的干草,留下一群饥饿的牛.他乘着容量为C(1≤C≤50000)个单位的马车,去顿因家买一些干草. 顿因有H(1≤H≤5000)包干草,每一包都有它的体积Vi(l≤Vi≤C).约翰只能整包购买,

    他最多可以运回多少体积的干草呢?

    输入输出格式

    输入格式:

    • Line 1: Two space-separated integers: C and H

    • Lines 2..H+1: Each line describes the volume of a single bale: V_i

    输出格式:

    • Line 1: A single integer which is the greatest volume of hay FJ can purchase given the list of bales for sale and constraints.

    输入输出样例

    输入样例#1:
    7 3 
    2 
    6 
    5 
    
    输出样例#1:
    7 
    

    说明

    The wagon holds 7 volumetric units; three bales are offered for sale with volumes of 2, 6, and 5 units, respectively.

    Buying the two smaller bales fills the wagon.

    思路:

      最后一个点诶。。。

      死活过不去;;

    来,上代码:

    #include <cstdio>
    #include <iostream>
    
    using namespace std;
    
    int if_z,n,m,dp[50005];
    
    char Cget;
    
    inline void in(int &now)
    {
        now=0,if_z=1,Cget=getchar();
        while(Cget>'9'||Cget<'0')
        {
            if(Cget=='-') if_z=-1;
            Cget=getchar();
        }
        while(Cget>='0'&&Cget<='9')
        {
            now=now*10+Cget-'0';
            Cget=getchar();
        }
        now*=if_z;
    }
    
    int main()
    {
        in(m),in(n);int pos;
        while(n--)
        {
            in(pos);
            //for(int i=m;i>=pos;i--) dp[i]=max(dp[i],dp[i-pos]+pos);
            for(int i=m;i>=pos;i--)
            {
                if(dp[i-pos]+pos>dp[i]) dp[i]=dp[i-pos]+pos;
            }
        }
        cout<<dp[m];
        return 0;
    }

    正解!

    #include <iostream>
    
    using namespace std;
    
    int n;
    
    int main()
    {
        cin>>n;
        cout<<n;
        return 0;
    }
  • 相关阅读:
    iOS开发之单例模式
    XCode 安装 Alcatraz包管理器失败的处理
    iOS "此证书由未知颁发机构签名"此问题的解决方法
    Android WebView 使用
    BaseActivity
    定时周期执行指定的任务 ScheduledExecutorService
    SQLite数据库浅谈
    android 图片缓存
    Android之drawable state各个属性详解
    Android应用中如何启动另一个应用
  • 原文地址:https://www.cnblogs.com/IUUUUUUUskyyy/p/6485999.html
Copyright © 2011-2022 走看看