zoukankan      html  css  js  c++  java
  • ARC 098 C

    Problem Statement

    There are N people standing in a row from west to east. Each person is facing east or west. The directions of the people is given as a string S of length N. The i-th person from the west is facing east if Si= E, and west if Si= W.

    You will appoint one of the N people as the leader, then command the rest of them to face in the direction of the leader. Here, we do not care which direction the leader is facing.

    The people in the row hate to change their directions, so you would like to select the leader so that the number of people who have to change their directions is minimized. Find the minimum number of people who have to change their directions.

    Constraints

    • 2≤N≤3×105
    • |S|=N
    • Si is E or W.

    Input

    Input is given from Standard Input in the following format:

    N
    S
    

    Output

    Print the minimum number of people who have to change their directions.

    Sample Input 1

    5
    WEEWW
    

    Sample Output 1

    1
    

    Assume that we appoint the third person from the west as the leader. Then, the first person from the west needs to face east and has to turn around. The other people do not need to change their directions, so the number of people who have to change their directions is 1 in this case. It is not possible to have 0 people who have to change their directions, so the answer is 1.

    Sample Input 2

    12
    WEWEWEEEWWWE
    

    Sample Output 2

    4
    

    Sample Input 3

    8
    WWWWWEEE
    

    Sample Output 3

    3

    模拟题

    #include<cstring>
    #include<iostream>
    #include<cstdio>
    #include<cstdlib>
    #include<algorithm>
    #include<ctime>
    #define ll long long
    using namespace std;
    const int maxn=300005;
    
    int n,qz[maxn],tot,ans=1<<30;
    char s[maxn];
    
    int main(){
    	scanf("%d",&n),scanf("%s",s+1);
    	for(int i=1;i<=n;i++) qz[i]=qz[i-1]+(s[i]=='E');
    	tot=qz[n];
    	for(int i=1;i<=n;i++) ans=min(ans,(i-1-qz[i-1])+(tot-qz[i]));
    	cout<<ans<<endl;
    	return 0;
    }
    

      

     
  • 相关阅读:
    移动端前端开发调试
    webkit图片滤镜
    ruby安装sass报错解决办法
    mongodb的查询语句学习摘要
    signedCookies
    [cookie篇]从cookie-parser中间件说起
    node.js下mongoose简单操作实例
    在ExpressJS中设置二级域名跨域共享Cookie
    Node.js开发工具、开发包、框架等总结
    hibernate框架学习笔记4:主键生成策略、对象状态
  • 原文地址:https://www.cnblogs.com/JYYHH/p/9095319.html
Copyright © 2011-2022 走看看