zoukankan      html  css  js  c++  java
  • AtCoder

    Problem Statement

    There are N piles of candies on the table. The piles are numbered 1 through N. At first, pile i contains ai candies.

    Snuke and Ciel are playing a game. They take alternating turns. Snuke goes first. In each turn, the current player must perform one of the following two operations:

    1. Choose a pile with the largest number of candies remaining, then eat all candies of that pile.
    2. From each pile with one or more candies remaining, eat one candy.

    The player who eats the last candy on the table, loses the game. Determine which player will win if both players play the game optimally.

    Constraints
    • 1N105
    • 1ai109
    Input

    The input is given from Standard Input in the following format:

    N
    a1 a2  aN
    
    Output

    If Snuke will win, print First. If Ciel will win, print Second.

    Sample Input 1
    2
    1 3
    
    Sample Output 1
    First
    

    At the beginning of the game, pile 2 contains the most candies. If Snuke eats all candies of this pile, Ciel has no choice but to eat the last candy.

    Sample Input 2
    3
    1 2 1
    
    Sample Output 2
    First
    

    If Snuke eats one candy from each pile, Ciel is again left with the last candy.

    Sample Input 3
    3
    1 2 3
    
    Sample Output 3
    Second

    (假设高度有序,从左到右递减)
    可以把问题转化成,初始在(0,0),有n个矩形拼成的凸多边形,第i个矩形是的左下角是(i-1,0),右上角是(i,h[i])。那么游戏就相当于每次只能向右或者向上走,不能走出多边形,问先手是否必胜。
    可以先画一画1*1的小正方形的情况,可以发现不论右上角是什么状态,左下角一定和它的状态一样 (右上角必败比较好发现,必胜的话要多画几个其他点的状态)。
    于是就可以直接暴力做了2333

    #include<bits/stdc++.h>
    #define ll long long
    using namespace std;
    const int N=100005;
    
    int a[N],n;
    bool sg;
    
    inline void solve(){
    	for(int i=1;i<=n;i++) if(i+1>a[i+1]){
    		for(int j=i+1;a[j]==i;j++) sg^=1;
    		sg|=(a[i]-i)&1,puts(sg?"First":"Second");
    		break;
    	}
    }
    
    int main(){
    	scanf("%d",&n);
    	for(int i=1;i<=n;i++) scanf("%d",a+i);
    	sort(a+1,a+n+1),reverse(a+1,a+n+1);
    	
    	solve();
    	
    	return 0;
    }
    

  • 相关阅读:
    时间操作、时间戳
    滚动条大于120px时,判断pc端的情况下,导航条固定定位
    通过js中的useragrent来判断设备是pc端还是移动端,跳转不同的地址
    js构建函数,点击按钮显示div,再点击按钮或其他区域,隐藏div
    localStorage用法总结
    轮播插件、原生js编写,弄懂这个,基本上各种轮播都可以自己写了
    (原)选择远比努力重要
    Java线程之间通信
    迪杰斯特拉(Java)
    FFTW中文参考
  • 原文地址:https://www.cnblogs.com/JYYHH/p/9250505.html
Copyright © 2011-2022 走看看