zoukankan      html  css  js  c++  java
  • PAT (Advanced Level) Practice 1070 Mooncake (25分)

    1.题目

    Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the region's culture. Now given the inventory amounts and the prices of all kinds of the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.

    Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand can be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).

    Input Specification:

    Each input file contains one test case. For each case, the first line contains 2 positive integers N (≤1000), the number of different kinds of mooncakes, and D (≤500 thousand tons), the maximum total demand of the market. Then the second line gives the positive inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.

    Sample Input:

    3 200
    180 150 100
    7.5 7.2 4.5
    

    Sample Output:

    9.45

    2.代码

    #include<iostream>
    #include<algorithm>
    using namespace std;
    struct node
    {
    	double inventory;
    	double prices;
    	double p;
    }list[1010];
    bool cmp(struct node&a, struct node &b)
    {
    	return a.p > b.p;
    }
    int main()
    {
    	int n, amount;
    	double sum = 0;
    	scanf("%d %d", &n, &amount);
    	for (int i = 0; i < n; i++)
    		scanf("%lf", &list[i].inventory);
    	for (int i = 0; i < n; i++)
    		scanf("%lf", &list[i].prices);
    	for (int i = 0; i < n; i++)
    		list[i].p = list[i].prices / list[i].inventory;
    	sort(list, list + n, cmp);
    	for (int i = 0; i < n; i++)
    	{
    		if (list[i].inventory > amount)
    		{
    			sum += list[i].p*amount;
    			break;
    		}
    		else
    		{
    			sum += list[i].p*list[i].inventory;
    			amount -= list[i].inventory;
    		}
    	}
    	printf("%.2f", sum);
    }
  • 相关阅读:
    python记录程序运行时间的三种方法
    LeetCode 922. 按奇偶排序数组 II 做题小结
    LeetCode 976. 三角形的最大周长 做题小结
    LeetCode 1122. 数组的相对排序 做题小结
    LeetCode1528. 重新排列字符串 做题小结
    LeetCode 738. 单调递增的数字 做题小结
    selenium——鼠标操作ActionChains:点击、滑动、拖动
    剑指 Offer 32
    剑指 Offer 32
    二叉树的应用:二叉排序树的删除
  • 原文地址:https://www.cnblogs.com/Jason66661010/p/12788818.html
Copyright © 2011-2022 走看看