zoukankan      html  css  js  c++  java
  • PAT (Advanced Level) Practice 1078 Hashing (25分) (平方探测)

    1.题目

    The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

    Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (≤10​4​​) and N (≤MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print "-" instead.

    Sample Input:

    4 4
    10 6 4 15
    

    Sample Output:

    0 1 4 -

    2.代码

    #include<iostream>
    #include<cmath>
    #include<vector>
    using namespace std;
    bool isprime(int n)
    {
    	if (n == 1)return false;
    	for (int i = 2; i <= sqrt(n); i++)
    	{
    		if (n%i == 0)return false;
    	}
    	return true;
    }
    int main()
    {
    	int msize, n,temp;
    	double count = 0;
    	vector<int>list;
    	scanf("%d %d", &msize, &n);
    	while (!isprime(msize))msize++;
    	list.resize(msize);
    	bool space = false;
    	for (int i = 0; i < n; i++)
    	{
    		scanf("%d", &temp);
    		bool ok = false;
    		for (int j = 0; j < msize; j++)
    		{
    			if (list[(temp%msize + j*j) % msize] == 0)
    			{
    				list[(temp%msize + j*j) % msize] = temp;
    				ok = true; printf("%s%d", space == false ? "" : " ", (temp%msize + j*j) % msize); space = true; break;
    			}
    		}
    		if (!ok)printf("%s-", space == false ? "" : " ");
    	}
    }
  • 相关阅读:
    99%的人都理解错了HTTP中GET与POST的区别
    idea 使用
    一道java算法题
    记一次jedis并发使用问题JedisException: Could not return the resource to the pool
    我珍藏的神兵利器
    记一次诡异的debug
    spring cloud config
    spring mvc 集成quartz
    git使用下
    Mongo--03 mongo副本集、备份与恢复
  • 原文地址:https://www.cnblogs.com/Jason66661010/p/12788825.html
Copyright © 2011-2022 走看看