zoukankan      html  css  js  c++  java
  • PAT (Advanced Level) Practice 1090 Highest Price in Supply Chain (25分) (DFS⭐⭐⭐)

    1.题目

    A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

    Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

    Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.

    Input Specification:

    Each input file contains one test case. For each case, The first line contains three positive numbers: N (≤10​5​​), the total number of the members in the supply chain (and hence they are numbered from 0 to N−1); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number S​i​​ is the index of the supplier for the i-th member. S​root​​ for the root supplier is defined to be −1. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers. It is guaranteed that the price will not exceed 10​10​​.

    Sample Input:

    9 1.80 1.00
    1 5 4 4 -1 4 5 3 6
    

    Sample Output:

    1.85 2

    2.题目分析

    使用vector数组记录自己的孩子节点,然后进行DFS遍历

    3.代码

    #include<iostream>
    #include<vector>
    using namespace std;
    vector<int>list[100010];
    int maxx = -1;
    int counts = 0;
    void DFS(int a, int times)
    {
    	if (list[a].size() == 0)
    	{
    		if (times > maxx)
    		{
    			maxx = times;
    			counts = 1;
    		}
    		else if (times == maxx)counts++;
    		return;
    	}
    	int len = list[a].size();
    	for (int i = 0; i < len; i++)
    	{
    		times++;
    		DFS(list[a][i], times);
    		times--;
    	}
    	return;
    }
    int main()
    {
    	int n,a;
    	double p, r;
    	scanf("%d %lf %lf", &n, &p, &r);
    
    	for (int i = 0; i < n; i++)
    	{
    		scanf("%d", &a);
    		if (a == -1)list[100001].push_back(i);
    		else list[a].push_back(i);
    	}
    	DFS(100001,0);
    	for (int i = 0; i < maxx-1; i++)
    		p = p*(1 + r / 100);
    	printf("%.2f %d", p, counts);
    }
  • 相关阅读:
    Java基础——方法
    JavaScript-JSON解析
    JavaScript—事件
    Window 浏览器窗口对象
    JavaScript 事件
    JavaEE——css字体样式效果
    JavaEE——CSS字体样式
    JavaEE——CSS3选择器
    JavaEE——css边框样式
    JavaEE——XML简介
  • 原文地址:https://www.cnblogs.com/Jason66661010/p/12788833.html
Copyright © 2011-2022 走看看