zoukankan      html  css  js  c++  java
  • PAT (Advanced Level) Practice 1109 Group Photo (25分)

    1.题目

    Formation is very important when taking a group photo. Given the rules of forming K rows with N people as the following:

    • The number of people in each row must be N/K (round down to the nearest integer), with all the extra people (if any) standing in the last row;

    • All the people in the rear row must be no shorter than anyone standing in the front rows;

    • In each row, the tallest one stands at the central position (which is defined to be the position (m/2+1), where m is the total number of people in that row, and the division result must be rounded down to the nearest integer);

    • In each row, other people must enter the row in non-increasing order of their heights, alternately taking their positions first to the right and then to the left of the tallest one (For example, given five people with their heights 190, 188, 186, 175, and 170, the final formation would be 175, 188, 190, 186, and 170. Here we assume that you are facing the group so your left-hand side is the right-hand side of the one at the central position.);

    • When there are many people having the same height, they must be ordered in alphabetical (increasing) order of their names, and it is guaranteed that there is no duplication of names.

    Now given the information of a group of people, you are supposed to write a program to output their formation.

    Input Specification:

    Each input file contains one test case. For each test case, the first line contains two positive integers N (≤10​4​​), the total number of people, and K (≤10), the total number of rows. Then N lines follow, each gives the name of a person (no more than 8 English letters without space) and his/her height (an integer in [30, 300]).

    Output Specification:

    For each case, print the formation -- that is, print the names of people in K lines. The names must be separated by exactly one space, but there must be no extra space at the end of each line. Note: since you are facing the group, people in the rear rows must be printed above the people in the front rows.

    Sample Input:

    10 3
    Tom 188
    Mike 170
    Eva 168
    Tim 160
    Joe 190
    Ann 168
    Bob 175
    Nick 186
    Amy 160
    John 159
    

    Sample Output:

    Bob Tom Joe Nick
    Ann Mike Eva
    Tim Amy John
    

    2.题目分析

    先让list排序,排好队后,一个一个往二维队伍out里放,先处理前面的,最后单处理最后一行。

    3.代码

    #include<iostream>
    #include<algorithm>
    #include<cstring>
    #include<string>
    using namespace std;
    struct node
    {
    	string name;
    	int height;
    }list[10001],out[11][10001];
    bool cmp(node&a, node &b)
    {
    	if (a.height == b.height)return a.name > b.name;
    	else return a.height < b.height;
    }
    int main()
    {
    	int n, k;
    	cin >> n >> k;
    	for (int i = 0; i < n; i++)
    		cin >> list[i].name >> list[i].height;
    	sort(list, list + n, cmp);
    	int t = n / k;
    	int mid = t / 2;
    	int s = 0;
    	int count;
    	for (s = 0; s < k-1; s++)
    	{
    		count = (s+1)*t-1;
    		out[s][mid] = list[count--];
    		for (int i = mid-1, j = mid+1 ; i >=0||j<=t - 1; i--, j++)
    		{
    			out[s][i] = list[count--];
    			out[s][j] = list[count--];
    		}
    	}
    	int last = n - (t*(k-1));
    	mid = last / 2;
    	n--;
    	out[s][mid] = list[n--];
    	for (int i = mid - 1 , j = mid + 1 ; i >=0 || j<=last - 1 ; i--, j++)
    	{
    		out[s][i] = list[n--];
    		out[s][j] = list[n--];
    	}
    	int space = 0;
    	for (int i = 0; i < last; i++)
    	{
    		if (space == 0) { cout << out[s][i].name; space++; }
    		else cout << ' ' << out[s][i].name;
    	}
    	cout << endl;
    	space = 0;
    	s--;
    	for (int i = s; i >= 0; i--)
    	{
    		space = 0;
    		for (int j = 0; j < t; j++)
    		{
    			if (space == 0) { cout << out[i][j].name; space++; }
    			else cout << ' ' << out[i][j].name;
    		}
    		s--;
    		cout << endl;
    	}
    
    }
  • 相关阅读:
    关于struts页面跳转的问题
    java中==和equals的区别
    控制广播风暴的方法
    广播风暴的成因及解决办法
    思科FEX配置
    思科vPC技术和配置
    数据中心架构TOR和EOR
    ARP表项及老化时间
    MAC地址表和老化时间
    track 3 list boolean or
  • 原文地址:https://www.cnblogs.com/Jason66661010/p/12788853.html
Copyright © 2011-2022 走看看