zoukankan      html  css  js  c++  java
  • PAT (Advanced Level) Practice 1113 Integer Set Partition (25分)

    1.题目

    Given a set of N (>1) positive integers, you are supposed to partition them into two disjoint sets A​1​​ and A​2​​ of n​1​​ and n​2​​ numbers, respectively. Let S​1​​ and S​2​​ denote the sums of all the numbers in A​1​​ and A​2​​, respectively. You are supposed to make the partition so that ∣n​1​​−n​2​​∣ is minimized first, and then ∣S​1​​−S​2​​∣ is maximized.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives an integer N (2≤N≤10​5​​), and then N positive integers follow in the next line, separated by spaces. It is guaranteed that all the integers and their sum are less than 2​31​​.

    Output Specification:

    For each case, print in a line two numbers: ∣n​1​​−n​2​​∣ and ∣S​1​​−S​2​​∣, separated by exactly one space.

    Sample Input 1:

    10
    23 8 10 99 46 2333 46 1 666 555
    

    Sample Output 1:

    0 3611
    

    Sample Input 2:

    13
    110 79 218 69 3721 100 29 135 2 6 13 5188 85
    

    Sample Output 2:

    1 9359

    2.代码

    我不敢相信就这么过了…………………………

    #include<iostream>
    #include<vector>
    #include<algorithm>
    using namespace std;
    int main()
    {
    	int n,sum1=0,sum2=0,count=0;
    	scanf("%d", &n);
    	vector<int>list(n);
    	for (int i = 0; i < n; i++)
    		scanf("%d", &list[i]);
    	sort(list.begin(), list.end());
    	if (n % 2 == 0)printf("0 ");
    	else printf("1 ");
    	for (auto it = list.begin(); it != list.end(); it++)
    	{
    		count++;
    		if (count <= list.size() / 2)
    			sum1 += *it;
    		else
    			sum2 += *it;
    	}
    	printf("%d", sum2 - sum1);
    }

     

  • 相关阅读:
    在命令提示符中使用antlr
    Migrating to Rails 2.0.2
    从AJAX IN ACTION书中学用 RSS READER
    maple download url
    搜索
    发邀请在线RoR开发与部署环境www.heroku.com
    if can't use ruby in command line
    查询表中某字段有重复记录的个数
    WPF窗体自适应分辨率
    《思考,快与慢》
  • 原文地址:https://www.cnblogs.com/Jason66661010/p/12788857.html
Copyright © 2011-2022 走看看