zoukankan      html  css  js  c++  java
  • POJ 2039 To and Fro

    To and Fro

    Description

    Mo and Larry have devised a way of encrypting messages. They first decide secretly on the number of columns and write the message (letters only) down the columns, padding with extra random letters so as to make a rectangular array of letters. For example, if the message is "There’s no place like home on a snowy night" and there are five columns, Mo would write down 
    t o i o y
    
    h p k n n
    e l e a i
    r a h s g
    e c o n h
    s e m o t
    n l e w x

    Note that Mo includes only letters and writes them all in lower case. In this example, Mo used the character "x" to pad the message out to make a rectangle, although he could have used any letter. 

    Mo then sends the message to Larry by writing the letters in each row, alternating left-to-right and right-to-left. So, the above would be encrypted as 

    toioynnkpheleaigshareconhtomesnlewx 

    Your job is to recover for Larry the original message (along with any extra padding letters) from the encrypted one. 

    Input

    There will be multiple input sets. Input for each set will consist of two lines. The first line will contain an integer in the range 2. . . 20 indicating the number of columns used. The next line is a string of up to 200 lower case letters. The last input set is followed by a line containing a single 0, indicating end of input.

    Output

    Each input set should generate one line of output, giving the original plaintext message, with no spaces.

    Sample Input

    5
    toioynnkpheleaigshareconhtomesnlewx
    3
    ttyohhieneesiaabss
    0

    Sample Output

    theresnoplacelikehomeonasnowynightx
    thisistheeasyoneab

    #include<iostream>
    #include<string>
    using namespace std;
    char a[400][400];
    
    int main()
    {
        string str;
        int column;
    
        while (cin >> column&&column != 0)
        {
            cin >> str;
    
            int row = str.length() / column ;
        
            for (int i = 0; i < row; i++)
                for (int j = 0; j < column; j++)
                    a[i][j] = str[i*column + ((i % 2 == 0) ? (j) : (column - j - 1))];
        
            for (int i = 0; i < column; i++)
                for (int j = 0; j < row; ++j)
                    cout << a[j][i];
        
            cout << endl;
        }
    
        return 0;
    }


  • 相关阅读:
    Android 架构 1.架构
    Android UI 统一修改Button控件的样式,以及其它系统控件的默认样式
    RobotFrameWork+APPIUM实现对安卓APK的自动化测试----第三篇【实例】
    RobotFrameWork+APPIUM实现对安卓APK的自动化测试----第二篇【原理】
    RobotFrameWork+APPIUM实现对安卓APK的自动化测试----第一篇【安装】
    选择日期控件
    robot Framework控制浏览器
    botot framework选择下拉框
    soapui测试接口使用步骤
    使用python实现appium的屏幕滑动
  • 原文地址:https://www.cnblogs.com/KennyRom/p/5831929.html
Copyright © 2011-2022 走看看