zoukankan      html  css  js  c++  java
  • 第四周 动态规划算法(2):1.UNIMODAL PALINDROMIC DECOMPOSITIONS

    总时间限制:
    1000ms
    内存限制:
    65536kB
    描述

    A sequence of positive integers is Palindromic if it reads the same forward and backward. For example:
    23 11 15 1 37 37 1 15 11 23
    1 1 2 3 4 7 7 10 7 7 4 3 2 1 1
    A Palindromic sequence is Unimodal Palindromic if the values do not decrease up to the middle value and then (since the sequence is palindromic) do not increase from the middle to the end For example, the first example sequence above is NOT Unimodal Palindromic while the second example is.
    A Unimodal Palindromic sequence is a Unimodal Palindromic Decomposition of an integer N, if the sum of the integers in the sequence is N. For example, all of the Unimodal Palindromic Decompositions of the first few integers are given below:
    1: (1)
    2: (2), (1 1)
    3: (3), (1 1 1)
    4: (4), (1 2 1), (2 2), (1 1 1 1)
    5: (5), (1 3 1), (1 1 1 1 1)
    6: (6), (1 4 1), (2 2 2), (1 1 2 1 1), (3 3),
    (1 2 2 1), ( 1 1 1 1 1 1)
    7: (7), (1 5 1), (2 3 2), (1 1 3 1 1), (1 1 1 1 1 1 1)
    8: (8), (1 6 1), (2 4 2), (1 1 4 1 1), (1 2 2 2 1),
    (1 1 1 2 1 1 1), ( 4 4), (1 3 3 1), (2 2 2 2),
    (1 1 2 2 1 1), (1 1 1 1 1 1 1 1)

    Write a program, which computes the number of Unimodal Palindromic Decompositions of an integer.

    输入
    Input consists of a sequence of positive integers, one per line ending with a 0 (zero) indicating the end.
    输出
    For each input value except the last, the output is a line containing the input value followed by a space, then the number of Unimodal Palindromic Decompositions of the input value. See the example on the next page.
    样例输入
    2
    3
    4
    5
    6
    7
    8
    10
    23
    24
    131
    213
    92
    0
    样例输出
    2 2
    3 2
    4 4
    5 3
    6 7
    7 5
    8 11
    10 17
    23 104
    24 199
    131 5010688
    213 1055852590
    92 331143
    提示
    N < 250
    #include <cstdio>
    #include <iostream>
    #include <algorithm>
    #include <string>
    #include <cstring>
    using namespace std;
    
    int main(int argc,const char *argv[])
    {
        int n = 0;
        long long num[255][255] = {0};
        
        for (int i = 1; i <= 251; ++i)
            for (int j = i; j >= 0; --j)
                num[i][j] = 1;
        
        for (int i = 0; i <= 251; ++i)
            num[0][i] = 1;
        
        for (int i = 2; i <= 251; ++i)
            for (int j = i / 2; j >= 1; --j)
                num[i][j] = num[i - 2 * j][j] + num[i][j + 1];
        while (true)
        {
            scanf("%d",&n);
            if(!n)
                break;
            printf("%d %lld\n",n,num[n][1]);
        }
        return 0;
    }
  • 相关阅读:
    SE知识整理——泛型
    IDEA 运行 SpringMVC 项目分发控制器出现404解决方案。
    快速幂/欧拉降幂
    Leetcode(双指针专题)
    剑指offer
    ns3参考
    网络知识1:最后一公里/WiMax / 4G
    备份2
    shell入门
    ns3_gdb:协议里的函数是怎么被调用的
  • 原文地址:https://www.cnblogs.com/Konayuki2015/p/4514273.html
Copyright © 2011-2022 走看看