zoukankan      html  css  js  c++  java
  • [POI2006] KRA-The Disks (贪心)

    题目描述

    For his birthday present little Johnny has received from his parents a new plaything which consists of a tube and a set of disks. The aforementioned tube is of unusual shape. Namely, it is made of a certain number of cylinders (of equal height) with apertures of different diameters carved coaxially through them. The tube is closed at the bottom, open at the top. An exemplary tube consisting of cylinders whose apertures have the diameters: 5cm, 6cm, 4cm, 3cm, 6cm, 2cm and 3cm is presented in the image below.

    The disks in Johnny's plaything are cylinders of different diameters and height equal to those forming the tube.

    Johnny has invented a following game: having a certain set of disks at his disposal, he seeks to find what depth the last of them would stop at, assuming that they are being thrown into the centre of the tube. If, for instance, we were to throw disks of consecutive diameters: 3cm, 2cm and 5cm, we would obtain the following situation:

    As you can see, upon being thrown in, every disk falls until it gets stuck (which means that it lies atop a cylinder, aperture of which has a diameter smaller than the diameter of the disk) or it is stopped by an obstacle: the bottom of the tube or another disk, which has already stopped.

    The game being difficult, Johnny constantly asks his parents for help. As Johnny's parents do not like such intellectual games, they have asked you - an acquaintance of theirs and a programmer - to write a programme which will provide them with answers to Johnny's questions.

    TaskWrite a programme which:

    reads the description of the tube and the disks which Johnny will throw into it from the standard input,computes the depth which the last disk thrown by Johnny stops at,writes the outcome to the standard output.

    一个框,告诉你每一层的宽度。

    向下丢给定宽度的木块。

    木块会停在卡住他的那一层之上,异或是已经存在的木块之上。

    询问丢的最后一个木块停在第几层。

    输入输出样例

    输入样例#1:

    7 3
    5 6 4 3 6 2 3
    3 2 5

    输出样例#1:

    2

    Solution

    要考虑到:

    • 每一个筒都只能使用一次
    • 若上面有一个较窄的入口,那么下方最多的能通过的就是该宽度。

    所以我们可以预先处理出一个可以通过的宽度大小的数组 (wide)
    其中: (wide[i]=min(wide[i],wide[i-1]))

    然后可以发现这个序列是满足升序的.既可以 O(n)或者 O(nlogn) 求解。

    代码

    #include<bits/stdc++.h>
    using namespace std;
    const int maxn=300008;
    int n,m;
    int wide[maxn];
    int last;
    
    int main()
    {
    	freopen("kra.in","r",stdin);
    	freopen("kra.out","w",stdout);
    	scanf("%d%d",&n,&m);
    	last=n+1;
    	for(int i=1;i<=n;i++)
    	scanf("%d",&wide[i]);
    	for(int i=2;i<=n;i++)
    		if(wide[i]>wide[i-1])
    			wide[i]=wide[i-1];
    	for(int i=1;i<=m;i++)
    	{
    		int x; 
    		scanf("%d",&x);
    		int mid,l=1,r=last-1;
    		while(l<=r)
    		{
    			mid=l+r>>1;
    			if(wide[mid]>=x) 
    			{last=mid;l=mid+1;}
    			else r=mid-1;
    		}
    	}
    	if(n>m)
    	cout<<last;
    	else 
    	cout<<0<<endl;
    	return 0;
    }
    
    
  • 相关阅读:
    SMTP 服务器要求安全连接或客户端未通过身份验证的各个解决方案(C#)
    远程数据同步的三种方法
    粗俗易懂的SQL存储过程在.NET中的实例运用之二
    SSIS脚本组件的代码
    浅谈C# StackTrace 类的实例说明
    解决了:无法加载文件或程序集'stdole, Version=7.0.3300.0'
    收藏: .NET中类型的转换
    WCF 实例 —— Android 短信助手 (WCF + Android)
    粗俗易懂的SQL存储过程在.NET中的实例运用
    此发送邮件的代码对吗?
  • 原文地址:https://www.cnblogs.com/Kv-Stalin/p/9313568.html
Copyright © 2011-2022 走看看