zoukankan      html  css  js  c++  java
  • HD1049Climbing Worm

    Problem Description

    An inch worm is at the bottom of a well n inches deep. It has enough energy to climb u inches every minute, but then has to rest a minute before climbing again. During the rest, it slips down d inches. The process of climbing and resting then repeats. How long before the worm climbs out of the well? We'll always count a portion of a minute as a whole minute and if the worm just reaches the top of the well at the end of its climbing, we'll assume the worm makes it out.

    Input

    There will be multiple problem instances. Each line will contain 3 positive integers n, u and d. These give the values mentioned in the paragraph above. Furthermore, you may assume d < u and n < 100. A value of n = 0 indicates end of output.

    Output

    Each input instance should generate a single integer on a line, indicating the number of minutes it takes for the worm to climb out of the well.

    Sample Input

    10 2 1 20 3 1 0 0 0

    Sample Output

    17 19

    水题,数学题,一次过

    #include<iostream>
    using namespace std;
    int main(){
        int a,b,c,d,time;
        while(cin>>a>>b>>c && !(a==0 && b==0 && c==0)){
            time = 0;
            d = ((a-b)/(b-c))*2;
            if((a-b)%(b-c)==0)
            {    time = d+1;}
            else
            {    time = d+3;}
            cout<<time<<endl;
        }
        return 0;
    }
  • 相关阅读:
    json转MAP
    责任链模式
    单例模式
    代理模式
    策略模式
    mysql触发器的使用
    Java 中的日期和时间
    MySQL插入数据前检测唯一性
    java字符串转为Map类型:split()方法的应用
    java Socket实例
  • 原文地址:https://www.cnblogs.com/LZYY/p/3292527.html
Copyright © 2011-2022 走看看