zoukankan      html  css  js  c++  java
  • HDU2389(二分图匹配Hopcroft-Carp算法)

    Rain on your Parade

    Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 655350/165535 K (Java/Others)
    Total Submission(s): 3310    Accepted Submission(s): 1066

    Problem Description
    You’re giving a party in the garden of your villa by the sea. The party is a huge success, and everyone is here. It’s a warm, sunny evening, and a soothing wind sends fresh, salty air from the sea. The evening is progressing just as you had imagined. It could be the perfect end of a beautiful day.
    But nothing ever is perfect. One of your guests works in weather forecasting. He suddenly yells, “I know that breeze! It means its going to rain heavily in just a few minutes!” Your guests all wear their best dresses and really would not like to get wet, hence they stand terrified when hearing the bad news.
    You have prepared a few umbrellas which can protect a few of your guests. The umbrellas are small, and since your guests are all slightly snobbish, no guest will share an umbrella with other guests. The umbrellas are spread across your (gigantic) garden, just like your guests. To complicate matters even more, some of your guests can’t run as fast as the others.
    Can you help your guests so that as many as possible find an umbrella before it starts to pour? 

    Given the positions and speeds of all your guests, the positions of the umbrellas, and the time until it starts to rain, find out how many of your guests can at most reach an umbrella. Two guests do not want to share an umbrella, however. 
     
    Input
    The input starts with a line containing a single integer, the number of test cases.
    Each test case starts with a line containing the time t in minutes until it will start to rain (1 <=t <= 5). The next line contains the number of guests m (1 <= m <= 3000), followed by m lines containing x- and y-coordinates as well as the speed si in units per minute (1 <= si <= 3000) of the guest as integers, separated by spaces. After the guests, a single line contains n (1 <= n <= 3000), the number of umbrellas, followed by n lines containing the integer coordinates of each umbrella, separated by a space.
    The absolute value of all coordinates is less than 10000.
     
    Output
    For each test case, write a line containing “Scenario #i:”, where i is the number of the test case starting at 1. Then, write a single line that contains the number of guests that can at most reach an umbrella before it starts to rain. Terminate every test case with a blank line.
     
    Sample Input
    2
    1
    2
    1 0 3
    3 0 3
    2
    4 0
    6 0
    1
    2
    1 1 2
    3 3 2
    2
    2 2
    4 4
     
    Sample Output
    Scenario #1: 2
     
    Scenario #2: 2
     
    Source
     
    这道题用匈牙利算法会超时,匈牙利算法复杂度O(V*E)
    Hopcroft-Carp算法复杂度O(sqrt(V)*E)
    /*
    ID: LinKArftc
    PROG: 2389.cpp
    LANG: C++
    */
    
    #include <map>
    #include <set>
    #include <cmath>
    #include <stack>
    #include <queue>
    #include <vector>
    #include <cstdio>
    #include <string>
    #include <utility>
    #include <cstdlib>
    #include <cstring>
    #include <iostream>
    #include <algorithm>
    using namespace std;
    #define eps 1e-8
    #define randin srand((unsigned int)time(NULL))
    #define input freopen("input.txt","r",stdin)
    #define debug(s) cout << "s = " << s << endl;
    #define outstars cout << "*************" << endl;
    const double PI = acos(-1.0);
    const double e = exp(1.0);
    const int inf = 0x3f3f3f3f;
    const int INF = 0x7fffffff;
    typedef long long ll;
    
    const int maxn = 3010;
    
    struct Node {
        double x, y, speed;
        Node() {}
        Node(double _x, double _y) : x(_x), y(_y) {}
        Node(double _x, double _y, double _s) : x(_x), y(_y), speed(_s) {}
    } men[maxn], un[maxn];
    
    vector<int>G[maxn];
    int uN, vN;
    int Mx[maxn],My[maxn];
    int dx[maxn],dy[maxn];
    int dis;
    bool used[maxn];
    bool SearchP()
    {
        queue<int>Q;
        dis = INF;
        memset(dx,-1,sizeof(dx));
        memset(dy,-1,sizeof(dy));
        for(int i = 1 ; i <= uN; i++)
            if(Mx[i] == -1)
            {
                Q.push(i);
                dx[i] = 0;
            }
        while(!Q.empty())
        {
            int u = Q.front();
            Q.pop();
            if(dx[u] > dis)break;
            int sz = G[u].size();
            for(int i = 0;i < sz;i++)
            {
                int v = G[u][i];
                if(dy[v] == -1)
                {
                    dy[v] = dx[u] + 1;
                    if(My[v] == -1)dis = dy[v];
                    else
                    {
                        dx[My[v]] = dy[v] + 1;
                        Q.push(My[v]);
                    }
                }
            }
        }
        return dis != INF;
    }
    bool DFS(int u)
    {
        int sz = G[u].size();
        for(int i = 0;i < sz;i++)
        {
            int v = G[u][i];
            if(!used[v] && dy[v] == dx[u] + 1)
            {
                used[v] = true;
                if(My[v] != -1 && dy[v] == dis)continue;
                if(My[v] == -1 || DFS(My[v]))
                {
                    My[v] = u;
                    Mx[u] = v;
                    return true;
                }
            }
        }
        return false;
    }
    int MaxMatch()
    {
        int res = 0;
        memset(Mx,-1,sizeof(Mx));
        memset(My,-1,sizeof(My));
        while(SearchP())
        {
            memset(used,false,sizeof(used));
            for(int i = 1;i <= uN;i++)
                if(Mx[i] == -1 && DFS(i))
                    res++;
        }
        return res;
    }
    
    int main() {
        //input;
        int T, t, _t = 1;
        scanf("%d", &T);
        while (T --) {
            scanf("%d", &t);
            scanf("%d", &uN);
            for (int i = 1; i <= uN; i ++) scanf("%lf %lf %lf", &men[i].x, &men[i].y, &men[i].speed);
            scanf("%d", &vN);
            for (int i = 1; i <= vN; i ++) scanf("%lf %lf", &un[i].x, &un[i].y);
            for (int i = 1; i <= uN; i ++) {
                G[i].clear();
                for (int j = 1; j <= vN; j ++) {
                    if (sqrt(fabs(men[i].x - un[j].x) * fabs(men[i].x - un[j].x) + fabs(men[i].y - un[j].y) * fabs(men[i].y - un[j].y)) - men[i].speed * t < eps) G[i].push_back(j);
                }
            }
            printf("Scenario #%d:
    %d
    
    ", _t ++, MaxMatch());
        }
    
        return 0;
    }
  • 相关阅读:
    浅谈求卡特兰数的几种方法
    WPF基础知识、界面布局及控件Binding
    .net平台下C#socket通信(上)
    .net泛型理解
    面向过程和面向对象及面向对象的三大特征
    C#配置文件管理
    MOGRE学习笔记(3)--MOGRE小项目练习
    委托、事件学习笔记
    MOGRE学习笔记(2)
    MOGRE学习笔记(1)
  • 原文地址:https://www.cnblogs.com/LinKArftc/p/4912145.html
Copyright © 2011-2022 走看看