zoukankan      html  css  js  c++  java
  • Hdoj 1102.Constructing Roads 题解

    Problem Description

    There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

    We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

    Input

    The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

    Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

    Output

    You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

    Sample Input

    3
    0 990 692
    990 0 179
    692 179 0
    1
    1 2
    

    Sample Output

    179
    

    Source

    kicc


    思路

    就是求最小生成树的问题,已经修过的路就把距离设置为0就好了,用的是Kruskal算法

    代码

    #include<bits/stdc++.h>
    using namespace std;
    int father[110];
    struct Graph
    {
    	int u;
    	int v;
    	int dis;
    }maps[10010];
    
    int grid[110][110];
    void init(int n)
    {
        for(int i=1;i<=n;i++) father[i]=i;
    }
    int find(int x)
    {
        while(father[x]!=x) x=father[x];
        return x;
    }
    void join(int a,int b)
    {
        int t1=find(a);
        int t2=find(b);
        if(t1!=t2) father[t1]=t2;
    }
    int getNum(int n)
    {
    	int num = 0;
    	for(int i=1;i<=n;i++)
    		if(father[i]==i)
    			num++;
    	return num;
    }
    int main()
    {
    	int n;
    	while(cin>>n)
    	{
    		memset(grid,0,sizeof(grid));
    		for(int i=1;i<=n;i++)
    			for(int j=1;j<=n;j++)
    				cin >> grid[i][j];
    		int q;
    		cin >> q;
    		while(q--)
    		{
    			int a,b;
    			cin >> a >> b;
    			grid[a][b] = 0;
    			grid[b][a] = 0;
    		}
    		
    		int edgeNum = 0;
    		for(int i=1;i<=n;i++)
    			for(int j=1;j<=n;j++)
    			{
    				if(i==j)continue;
    				maps[++edgeNum].u = i;
    				maps[edgeNum].v = j;
    				maps[edgeNum].dis = grid[i][j];
    			}
    		sort(maps+1,maps+1+edgeNum,[](Graph x,Graph y)->bool{ return x.dis<y.dis;});
    		init(n);
    		int distance = 0;
    		for(int i=1;i<=edgeNum;i++)
    		{
    			if(find(maps[i].u) != find(maps[i].v))
    			{
    				join(maps[i].u,maps[i].v);
    				distance += maps[i].dis;
    			}
    		}
    		cout << distance << endl;
    	}
    	return 0;
    }
    
  • 相关阅读:
    gym 101480 Problem C: Cow Confinement 题解
    Uva 1072 Huffman Codes 题解
    NERC 2015 Hypercube 题解
    ACM ICPC 2017 WF Problem J Son of Pipe Stream题解
    CF Round # 295 (Div. 1)题解
    CF 1444 D Rectangular Polyline 题解
    BZOJ3308 九月的咖啡店
    BZOJ4025 二分图
    BZOJ4000 [TJOI2015]棋盘
    BZOJ3999 [TJOI2015]旅游
  • 原文地址:https://www.cnblogs.com/MartinLwx/p/10042340.html
Copyright © 2011-2022 走看看