zoukankan      html  css  js  c++  java
  • PTA (Advanced Level)1035.Password

    To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

    Input Specification:

    Each input file contains one test case. Each case contains a positive integer N (≤1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

    Output Specification:

    For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line There are N accounts and no account is modified where N is the total number of accounts. However, if N is one, you must print There is 1 account and no account is modified instead.

    Sample Input 1:
    3
    Team000002 Rlsp0dfa
    Team000003 perfectpwd
    Team000001 R1spOdfa
    
    Sample Output 1:
    2
    Team000002 RLsp%dfa
    Team000001 R@spodfa
    
    Sample Input 2:
    1
    team110 abcdefg332
    
    Sample Output 2:
    There is 1 account and no account is modified
    
    Sample Input 3:
    2
    team110 abcdefg222
    team220 abcdefg333
    
    Sample Output 3:
    There are 2 accounts and no account is modified
    
    思路
    • 用结构体表示数据,如果密码需要修改的就放到结构体数组里,最后根据修改的数量和n的大小来决定输出
    代码
    #include<bits/stdc++.h>
    using namespace std;
    struct user
    {
    	string id;
    	string password;
    }a[1010];
    int a_num = 0;
    int main()
    {
    	int n;
    	cin >> n;
    	string id, ps;
    	bool modify = false;
    	for(int j=0;j<n;j++)
    	{
    		cin >> id >> ps;
    		modify = false;	//表示有无修改过
    		for(int i=0;i<ps.size();i++)
    		{
    			if(ps[i] == '1')
    			{
    				modify = true;
    				ps[i] = '@';
    			}else
    			if(ps[i] == '0')
    			{
    				modify = true;
    				ps[i] = '%';
    			}else
    			if(ps[i] == 'l')
    			{
    				modify = true;
    				ps[i] = 'L';
    			}else
    			if(ps[i] == 'O')
    			{
    				modify = true;
    				ps[i] = 'o';
    			}
    		}
    		if(modify)
    		{
    			a[a_num].id = id;
    			a[a_num++].password = ps;
    		}
    	}
    	if(a_num == 0)
            if(n != 1)
                printf("There are %d accounts and no account is modified", n);
            else
                printf("There is 1 account and no account is modified");
    	else
    	{
    		cout << a_num<< endl;
    		for(int i=0;i<a_num;i++)
    		{
    			cout << a[i].id << " " << a[i].password;
    			cout << endl;
    		}
    	}
    	return 0;
    }
    
    
    
    引用

    https://pintia.cn/problem-sets/994805342720868352/problems/994805454989803520

  • 相关阅读:
    titanium开发教程0206创建多行的选择器
    titanium开发教程0210创建的文本字段与嵌入的按钮
    titanium开发教程0209配置文本域和文本区键盘类型
    titanium开发教程0301理解tab group
    titanium开发教程0205创建单行的选择器
    linux shell删除文本每行末尾的单个或者多个空格或者制表符
    R语言中scale函数的用法
    R语言中批量提取当前目录中指定类型的文件
    python中提取包含指定字符的行、提取以指定字符开头、指定字符结尾的行
    python中如何统计文件的行数
  • 原文地址:https://www.cnblogs.com/MartinLwx/p/11706915.html
Copyright © 2011-2022 走看看