zoukankan      html  css  js  c++  java
  • Hdoj 1050.Moving Tables 题解

    Problem Description

    The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.
    img
    The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.
    img
    For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.

    Input

    The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.

    Output

    The output should contain the minimum time in minutes to complete the moving, one per line.

    Sample Input

    3 
    4 
    10 20 
    30 40 
    50 60 
    70 80 
    2 
    1 3 
    2 200 
    3 
    10 100 
    20 80 
    30 50 
    

    Sample Output

    10
    20
    30
    

    Source

    Asia 2001, Taejon (South Korea)


    思路

    两个思路:

    代码(思路一)

    #include<bits/stdc++.h>
    using namespace std;
    int a[210];
    int cor(int x)
    {
    	return x%2==0 ? x/2 : (x+1)/2;
    }//返回走廊位置 
    int main()
    {
    	int t;
    	while(cin>>t)
    	{
    		for(int i=1;i<=t;i++)
    		{
    			int n;
    			cin >> n;
    			int l,r;
    			memset(a,0,sizeof(a));
    			for(int j=1;j<=n;j++)
    			{
    				scanf("%d%d",&l,&r);
    				if(l>r)
    				{
    					int t;
    					t = l; l = r; r = t;
    				}
    				int corl = cor(l);
    				int corr = cor(r); 
    				for(int k=corl;k<=corr;k++)
    					a[k]++;
    			}
    			//for(int j=1;j<=30;j++)	cout<<a[j]<<" ";
    			int max_value = -1;
    			for(int j=1;j<=201;j++)
    				if(a[j]>max_value)
    					max_value = a[j];
    			
    			if(max_value==0)
    				cout << 10 << endl;
    			else
    				cout << max_value*10 << endl;
    		}
    	}
    	return 0;	
    }
    
    如有转载,请注明出处QAQ
  • 相关阅读:
    两个python程序搞定NCBI数据搜索并将结果保存到excel里面
    在notepad++上如何配置Python C 以及 java
    初识pandas
    关于搜索全部文件和修改文件名的方法os.walk() 和os.listdir
    C算法--指针与函数参数
    C算法--指针与数组
    C算法--指针1
    C算法--函数
    C算法--string.h头文件
    C算法--字符数组
  • 原文地址:https://www.cnblogs.com/MartinLwx/p/9775542.html
Copyright © 2011-2022 走看看