zoukankan      html  css  js  c++  java
  • Hdoj 1312.Red and Black 题解

    Problem Description

    There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

    Write a program to count the number of black tiles which he can reach by repeating the moves described above.

    Input

    The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

    There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

    '.' - a black tile
    '#' - a red tile
    '@' - a man on a black tile(appears exactly once in a data set)

    Output

    For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

    Sample Input

    6 9
    ....#.
    .....#
    ......
    ......
    ......
    ......
    ......
    #@...#
    .#..#.
    11 9
    .#.........
    .#.#######.
    .#.#.....#.
    .#.#.###.#.
    .#.#..@#.#.
    .#.#####.#.
    .#.......#.
    .#########.
    ...........
    11 6
    ..#..#..#..
    ..#..#..#..
    ..#..#..###
    ..#..#..#@.
    ..#..#..#..
    ..#..#..#..
    7 7
    ..#.#..
    ..#.#..
    ###.###
    ...@...
    ###.###
    ..#.#..
    ..#.#..
    0 0
    

    Sample Output

    45
    59
    6
    13
    

    Source

    Asia 2004, Ehime (Japan), Japan Domestic


    思路

    平平无奇的一道简单bfs问题,只要每次广搜入队的时候都统计一次就好了,最后返回结果并输出

    代码

    #include<bits/stdc++.h>
    using namespace std;
    int a,b,c,t;
    const int d[][2]={ {-1,0},{0,1},{1,0},{0,-1} };
    struct node
    {
    	int x;
    	int y;
    }st,ed;
    int n,m;
    char maps[21][21];
    bool judge(node x)
    {
    	if(x.x<=m && x.x>=1 && x.y<=n && x.y>=1 && maps[x.x][x.y]=='.')
    		return true;
    	return false;
    }
    int bfs(node st)
    {
    	queue<node> q;
    	q.push(st);
    	maps[st.x][st.y] = '#';
    	node now,next;
    	int t = 0;
    	while(!q.empty())
    	{
    		now = q.front();
    		q.pop();
    		for(int i=0;i<4;i++)
    		{
    			next.x = now.x + d[i][0];
    			next.y = now.y + d[i][1];			
    			if(judge(next))
    			{
    				q.push(next);
    				t++;
    				maps[next.x][next.y] = '#';
    			}
    		}
    
    	}
    	return t+1;//起点也算
    }
    		
    int main()
    {
    	while(cin>>n>>m)
    	{
    		if(n==0 && m==0) break;
    		for(int i=1;i<=m;i++)
    			for(int j=1;j<=n;j++)
    			{
    				cin >> maps[i][j];
    				if(maps[i][j]=='@')
    				{
    					st.x = i; st.y = j;
    				}
    			}
    		int ans = bfs(st);
    		cout << ans << endl;
    	}
    	return 0;
    }
    
  • 相关阅读:
    遇到的开发错误
    我的麦本本配置
    C#:100以内能被7整除的最大自然数
    C#:静态字段和静态方法的学习
    Oracle 备份、恢复单表或多表数据步骤 (转)
    有关关键路径的概念和算法 (转)
    Delphi中StringReplace函数的使用
    Delphi 里 FillChar的用法
    Delphi中destroy, free, freeAndNil, release用法和区别
    项目经理、系统架构师或技术骨干应该具备的水平
  • 原文地址:https://www.cnblogs.com/MartinLwx/p/9902686.html
Copyright © 2011-2022 走看看