zoukankan      html  css  js  c++  java
  • Exponentiation

    Description

    Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems.

    This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999) and n is an integer such that $0 < n le 25$.

    Input

    The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

    Output

    The output will consist of one line for each line of input giving the exact value of Rn. Leading zeros and insignificant trailing zeros should be suppressed in the output.

    Sample Input

    95.123 12
    0.4321 20
    5.1234 15
    6.7592  9
    98.999 10
    1.0100 12

    Sample Output

    548815620517731830194541.899025343415715973535967221869852721
    .00000005148554641076956121994511276767154838481760200726351203835429763013462401
    43992025569.928573701266488041146654993318703707511666295476720493953024
    29448126.764121021618164430206909037173276672
    90429072743629540498.107596019456651774561044010001
    1.126825030131969720661201

    HINT

    #include<iostream>
    #include<string.h>
    using namespace std;
    int main()
    {
    	char str[1000],a[1000],a1[1000];
    	int c;
    	int n,i,j,k,t,x,num,t1,t2,y,y1,y2;
    	while(cin>>str>>n)
    	{
    	
    		x=0;num=0;
    		t=strlen(str);
    		for(i=0;i<t;i++)
    		{
    			if(str[i]=='.')
    			{
    				num=t-1-i;
    				i++;
    			}
    			a[x]=str[i];
    			a1[x++]=str[i];
    		}
    		a[x]='';
    		a1[x]='';
    		num*=n;
    		int x1=x;
    		for(i=0;i<n-1;i++)
    		{	
    			int sum[1000]={0};
    			t1=999;t2=999;
    			for(j=x-1;j>=0;j--)
    			{
    				for(k=x1-1;k>=0;k--)
    					sum[t1--]+=((a[j]-'0')*(a1[k]-'0'));
    				t2--;
    			    t1=t2;
    			}
    		    c=0;
    			for(y=999;y>=0;y--)
    			{
    				sum[y]+=c;
    				c=0;
    				if(sum[y]>9)
    				{
    					c=sum[y]/10;
    					sum[y]=sum[y]%10;
    				}
    			}
    			for(y1=0;y1<1000;y1++)
    			{
    				if(sum[y1]!=0)
    					break;
    			}
    			x1=0;
    			for(y2=y1;y2<1000;y2++)
    				a1[x1++]=sum[y2]+'0';
    			a1[x1]='';
    		}
    		if(num==0)
    			cout<<a1<<endl;
    		else
    		{
    			t=strlen(a1);
    			if(a1[t-1]=='0')//若(2.0, 2)则输出4而不是4.00,多余的零去掉
    			{
    				for(i=t-1;i>=0;i--)
    				{
    					if(a1[i]!='0')
    						break;
    					num--;//小数点的位数
    				}
    				t=i+1;
    			}
    			for(i=0;i<t-num;i++)
    				cout<<a1[i];//输出小数点之前的
    			cout<<".";
    			while(num>t-i)//若整数部分为0,小数部分不够填补小数点后的位数0
    			{
    				cout<<"0";
    				num--;
    			}
    			for(j=i;j<t;j++)
    				cout<<a1[j];//输出小数点后的
    			cout<<endl;
    		}
    	}
    	return 0;
    }



     

  • 相关阅读:
    在ASP.NET开始执行HTTP请求的处理程序之前
    要在一般处理程序中获取其他页面的session值
    asp.net中session的原理及应用
    INTRAWEB说明书
    ASP.NET万能JSON解析器
    使用 IntraWeb (30)
    IntraWeb例子练习
    【整理】Asp.net HttpWebRequest和HttpWebResponse发送和接受任何类型数据
    Delphi 接口机制真相
    http://www.doc88.com/p-203939126010.html
  • 原文地址:https://www.cnblogs.com/NYNU-ACM/p/4237321.html
Copyright © 2011-2022 走看看