zoukankan      html  css  js  c++  java
  • Integer Inquiry(大数相加)

    Description

    One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.

    ``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)

    Input

    The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

    The final input line will contain a single zero on a line by itself.

    Output

    Your program should output the sum of the VeryLongIntegers given in the input.

    Sample Input

    123456789012345678901234567890
    123456789012345678901234567890
    123456789012345678901234567890
    0

    Sample Output

    370370367037037036703703703670
    #include<iostream>
    #include<string.h>
    using namespace std;
    int main()
    {
    	char a[1000];	
    	int i,j,x;
        while(cin>>a)
    	{
    		int sum[101]={0};
    		while(1)
    		{
    			int b[100]={0};
    			if(strcmp(a,"0")==0)
    				break;
    			int t=strlen(a);
    			x=99;
    			for(i=t-1;i>=0;i--)
    				b[x--]=a[i]-'0';
    			for(i=0;i<100;i++)
    				sum[i]+=b[i];
    			x=0;
    			for(i=99;i>=0;i--)
    			{
    				sum[i]+=x;
    				x=0;
    			    if(sum[i]>9)
    				{
    					x=sum[i]/10;
    				    sum[i]=sum[i]%10;
    				}
    			}
    			cin>>a;
    		}
    		for(i=0;i<100;i++)
    		{
    			if(sum[i]!=0)
    				break;
    		}
    		for(j=i;j<100;j++)
    			cout<<sum[j];
    		cout<<endl;
    	}
    	return 0;
    }

  • 相关阅读:
    sqlzoo练习答案--SUM and COUNT
    响应式的嵌入内容和图片
    缓存server设计与实现(五)
    编译器DIY——读文件
    [Leetcode]-Pascal&#39;s Triangle
    zoj 1562 反素数 附上个人对反素数性质的证明
    [POJ 1236][IOI 1996]Network of Schools
    POJ 3691 DNA repair [AC自动机 DP]
    POJ 1625 Censored! [AC自动机 高精度]
    51Nod 1225 余数之和 [整除分块]
  • 原文地址:https://www.cnblogs.com/NYNU-ACM/p/4237324.html
Copyright © 2011-2022 走看看