Submit: 2254 Solved: 934
[Submit][Status][Discuss]
Description
已知一个长度为n的正整数序列A(下标从1开始), 令 S = { x | 1 <= x <= n }, S 的幂集2^S定义为S 所有子
集构成的集合。定义映射 f : 2^S -> Zf(空集) = 0f(T) = XOR A[t] , 对于一切t属于T现在albus把2^S中每个集
合的f值计算出来, 从小到大排成一行, 记为序列B(下标从1开始)。 给定一个数, 那么这个数在序列B中第1
次出现时的下标是多少呢?
Input
第一行一个数n, 为序列A的长度。接下来一行n个数, 为序列A, 用空格隔开。最后一个数Q, 为给定的数.
Output
共一行, 一个整数, 为Q在序列B中第一次出现时的下标模10086的值.
Sample Input
3
1 2 3
1
1 2 3
1
Sample Output
3
样例解释:
N = 3, A = [1 2 3]
S = {1, 2, 3}
2^S = {空, {1}, {2}, {3}, {1, 2}, {1, 3}, {2, 3}, {1, 2, 3}}
f(空) = 0
f({1}) = 1
f({2}) = 2
f({3}) = 3
f({1, 2}) = 1 xor 2 = 3
f({1, 3}) = 1 xor 3 = 2
f({2, 3}) = 2 xor 3 = 1
f({1, 2, 3}) = 0
所以
B = [0, 0, 1, 1, 2, 2, 3, 3]
样例解释:
N = 3, A = [1 2 3]
S = {1, 2, 3}
2^S = {空, {1}, {2}, {3}, {1, 2}, {1, 3}, {2, 3}, {1, 2, 3}}
f(空) = 0
f({1}) = 1
f({2}) = 2
f({3}) = 3
f({1, 2}) = 1 xor 2 = 3
f({1, 3}) = 1 xor 3 = 2
f({2, 3}) = 2 xor 3 = 1
f({1, 2, 3}) = 0
所以
B = [0, 0, 1, 1, 2, 2, 3, 3]
HINT
数据范围:
1 <= N <= 10,0000
其他所有输入均不超过10^9
Source
题解:
问题即求子集异或和的某个数的排名;
线性基的性质:若$A,|A|=n$的线性基为$B$,$|B|=k$,则有$2^k$个不同的子集异或和,且每个会出现$2^{n-k}$次;
由基的线性无关性可以知道有且仅有$2^k$个异或和互不相同; 这k个基是可以从$a_i$里选出来的,只是我们为了好写,一般插入就直接消元到某个数组里; 考虑他们的子集异或和S1,另外有$n-k$个数,可以被B中的向量唯一表示,考虑子集异或和S2 ; S1 ^ S2 也是一种合法的选法; 这样有$2^k * 2^{n-k} = 2^n$种 ,说明只有$2^n$且按照这种方式对应;
高斯亚当消元求出互相独立的线性基,在线性基上一个一个查找;
注意消元的两个循环(line23 line24 )有顺序;
复杂度;$ O(n log a_{i} + log a_{i}) $
20181030
1 #include<cstdio> 2 #include<iostream> 3 #include<algorithm> 4 #include<cstring> 5 #include<queue> 6 #include<cmath> 7 #include<vector> 8 #include<stack> 9 #include<map> 10 #include<set> 11 #define Run(i,l,r) for(int i=l;i<=r;i++) 12 #define Don(i,l,r) for(int i=l;i>=r;i--) 13 #define ll long long 14 #define inf 0x3f3f3f3f 15 using namespace std; 16 const int N=100010 , mod=10086; 17 int n,d[31],q; 18 void ins(int x){ 19 for(int i=29;~i;i--)if((x>>i)&1){ 20 if(!d[i]){ 21 d[i]=x; 22 for(int j=0;j<i;j++)if(d[j]&&((d[i]>>j)&1))d[i]^=d[j]; 23 for(int j=29;j>i;j--)if((d[j]>>i)&1)d[j]^=d[i]; 24 break; 25 } 26 else x^=d[i]; 27 } 28 } 29 int pw(int x,int y){ 30 int re=1; 31 while(y){ 32 if(y&1)re=re*x%mod; 33 y>>=1;x=x*x%mod; 34 } 35 return re; 36 } 37 int query(int x){ 38 int re=0,cnt=0; 39 for(int i=29;~i;i--)if(d[i])cnt++; 40 int tmp=cnt; 41 for(int i=29;~i;i--)if(d[i]){ 42 tmp--; 43 if((x^d[i])<x){ 44 x^=d[i]; 45 re=(re+pw(2,tmp))%mod; 46 } 47 } 48 re=re*pw(2,n-cnt)%mod; 49 return re; 50 } 51 int main(){ 52 freopen("in.in","r",stdin); 53 freopen("out.out","w",stdout); 54 scanf("%d",&n); 55 Run(i,1,n){ 56 int x;scanf("%d",&x); 57 ins(x); 58 } 59 int x;scanf("%d",&x); 60 cout<<(query(x)+1)%mod<<endl; 61 return 0; 62 }//by tkys_Austin;