zoukankan      html  css  js  c++  java
  • 和与绝对值差

    Problem F: F

    Time Limit: 1 Sec  Memory Limit: 128 MB
    Submit: 221  Solved: 56
    [Submit][Status][Web Board]

    Description

    Superbowl Sunday is nearly here. In order to pass the time waiting for the half-time commercials and wardrobe malfunctions, the local hackers have organized a betting pool on the game. Members place their bets on the sum of the two final scores, or on the absolute difference between the two scores.
    Given the winning numbers for each type of bet, can you deduce the final scores?

    Input

    The first line of input contains n, the number of test cases. n lines follow, each representing a test case. Each test case gives s and d, non-negative integers representing the sum and (absolute) difference between the two final scores.

    Output

    For each test case, output a line giving the two final scores, largest first. If there are no such scores, output a line containing "impossible". Recall that football scores are always non-negative integers.

    Sample Input

    2
    40 20
    20 40

    Sample Output

    30 10
    impossible
    

    对应的程序如下:

    #include <stdio.h>
    #include <stdlib.h>
    #include<math.h>
    int max(int x,int y)
    {
        return x>y?x:y;    
    }
    int main()
    {
          int n,s,d,p,q,m;
          while(scanf("%d",&n)!=EOF)
          {
              while(n-->0)
              {
                 scanf("%d%d",&s,&d);      
                 if(s>=d&&(s-d)%2==0) 
                 {
                    m=max(p,q);   
                    m=(d+s)/2;
                    printf("%d %d\n",m,s-m);       
                 }
                 else
                  printf("impossible\n");
              }                       
          }
          //system("pause");
         return 0;
    }
    或者简单的:

    #include"stdio.h"
    #include"stdlib.h"
    #include"math.h"
    int main()
    {
       int n,s,d,p,q,m;
       while(scanf("%d",&n)!=EOF)
       {
          while(n-->0)
          {
             scanf("%d%d",&s,&d);
             if(s>=d&&(s-d)%2==0)
             {
                 m=(s+d)/2;                        
                 printf("%d %d\n",m,s-m);
             }
             else
                  printf("impossible\n");
          }                        
       }   
        //system("pause");
        return  0;
    }

  • 相关阅读:
    SAP系统玩阴的?
    SAP MM 采购信息记录中价格单位转换因子的修改
    SAP MM 特殊库存之T库存初探
    Gnome增加消息提醒extension ( Fedora 28 )
    Arch Linux 更新源(以清华 arch 源为例)
    fedora 28 , firewalld 防火墙控制,firewall-cmd 管理防火墙规则
    apache 访问权限出错,apache selinux 权限问题, (13) Permission Denied
    什么是中间件? (保持更新)
    systemd 和 如何修改和创建一个 systemd service (Understanding and administering systemd)
    进入正在运行的 docker 容器(docker container)
  • 原文地址:https://www.cnblogs.com/QQbai/p/2122223.html
Copyright © 2011-2022 走看看