zoukankan      html  css  js  c++  java
  • 二分答案 [Usaco2014 Mar]Sabotage

    问题 L: [Usaco2014 Mar]Sabotage
    时间限制: 1 Sec 内存限制: 128 MB
    题目描述
    Farmer John”s arch-nemesis, Farmer Paul, has decided to sabotage Farmer John”s milking equipment! The milking equipment consists of a row of N (3 <= N <= 100,000) milking machines, where the ith machine produces M_i units of milk (1 <= M_i <= 10,000). Farmer Paul plans to disconnect a contiguous block of these machines – from the ith machine up to the jth machine (2 <= i <= j <= N-1); note that Farmer Paul does not want to disconnect either the first or the last machine, since this will make his plot too easy to discover. Farmer Paul”s goal is to minimize the average milk production of the remaining machines. Farmer Paul plans to remove at least 1 cow, even if it would be better for him to avoid sabotage entirely. Fortunately, Farmer John has learned of Farmer Paul”s evil plot, and he is wondering how bad his milk production will suffer if the plot succeeds. Please help Farmer John figure out the minimum average milk production of the remaining machines if Farmer Paul does succeed.

    约翰的牧场里有 N 台机器,第 i 台机器的工作能力为 Ai。保罗阴谋破坏一些机器,使得约翰的
    工作效率变低。保罗可以任意选取一段编号连续的机器,使它们停止工作。但这样的破坏只能搞一次,
    而且保罗无法破坏第一台或最后一台机器。请问他该破坏哪些机器才能让剩下机器的工作效率的平均
    数最小?为了显示存在感,保罗至少必须破坏一台机器。
    输入
    * Line 1: The integer N.
    * Lines 2..1+N: Line i+1 contains M_i.
    输出
    * Line 1: The lowest possible average Farmer Paul can achieve, rounded to 3 digits after the decimal point, and printed with 3 digits after the decimal point.

    样例输入
    5
    5
    1
    7
    8
    2
    样例输出
    2.667
    OUTPUT DETAILS: The optimal solution is to remove the 7 and 8, leaving 5, 1, and 2, whose average is 8/3.

    可以发现,答案的大小是满足单调性的,那么真的是二分答案。
    设当前check的答案是x,sum[i]为前缀和。
    那么满足(sum[n]-sum[r]+sum[l-1])/(n-(r-l+1))<=x即可满足
    化简一下sum[n]-x*n-(sum[r]-r*x)+(sum[l-1]-(l-1)*x)<=0;
    考虑如何把效率降为O(N),可以发现sum[l-1]-(l-1)*x越小越好。而且r在不断枚举,因此l就可以不断更新成最小值,就不必枚举了。

    #include<cstdio>
    #include<cstdlib>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    #define N 100005
    using namespace std;
    int n,sum[N];
    double ans;
    inline bool check(double x)
    {
        double k=(double)sum[1]-x,l=(double)sum[n]-(double)x*n;
        for(int i=2;i<n;i++)
        {
            if(l-sum[i]+i*x+k<=0)return 1;
            k=min(k,(double)sum[i]-i*x);
        }
        return 0;
    }
    int main()
    {
        cin>>n;
        for(int i=1;i<=n;i++)scanf("%d",&sum[i]),sum[i]+=sum[i-1];
        double l=0.0,r=(double)sum[n],mid;
        while(r-l>1e-8)
        {
            mid=(l+r)/2;
            if(check(mid))ans=mid,r=mid;
            else l=mid;
        }
        printf("%.3lf",ans);
    }
  • 相关阅读:
    浅析String.intern()方法
    com.alibaba.druid.pool.DruidPooledConnection cannot be cast to oracle.jdbc.OracleConnection 异常解决办法
    ChannelEventRunnable handle RECEIVED operation error, channel is NettyChannel解决方法
    jsch channel is not opened原因及解决
    学习地址(oraclemysqllinux)
    python中数据分析常用函数整理
    Python之使用Pandas库实现MySQL数据库的读写
    Python数据分析
    如何用sql查询出连续三个月金额大于50的记录
    【Python项目实战】Pandas:让你像写SQL一样做数据分析(一)
  • 原文地址:https://www.cnblogs.com/QTY2001/p/7632679.html
Copyright © 2011-2022 走看看