zoukankan      html  css  js  c++  java
  • 1012. The Best Rank (25)

    To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algebra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

    For example, The grades of C, M, E and A - Average of 4 students are given as the following:

    StudentID  C  M  E  A
    310101     98 85 88 90
    310102     70 95 88 84
    310103     82 87 94 88
    310104     91 91 91 91
    

    Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

    Input

    Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (<=2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

    Output

    For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

    The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

    If a student is not on the grading list, simply output "N/A".

    Sample Input
    5 6
    310101 98 85 88
    310102 70 95 88
    310103 82 87 94
    310104 91 91 91
    310105 85 90 90
    310101
    310102
    310103
    310104
    310105
    999999
    
    Sample Output
    1 C
    1 M
    1 E
    1 A
    3 A
    N/A
    




    题目不难,就是自己代码写的好渣..
    就有一个情况第一次没考虑到,就是出现相同排名的时候,修改后就过了

    #include <iostream>
    #include <map>
    #include <cstdio>
    
    using namespace std;
    
    typedef struct Student{
       string ID;
       int c;
       int m;
       int e;
       int a;
    }Student;
    
    Student s[2005];
    string CID[2005];
    map<string,int> a;
    map<string,int> c;
    map<string,int> m;
    map<string,int> e;
    
    int main()
    {
        int n,k;
        char t;
        cin>>n>>k;
        for(int i=0;i<n;i++){
            cin>>s[i].ID>>s[i].c>>s[i].m>>s[i].e;
            s[i].a=(s[i].c+s[i].m+s[i].e)/3;
        }
        Student temp;
        for(int i=0;i<n;i++){
            for(int j=i;j<n;j++){
                if(s[i].a<s[j].a){
                    temp=s[i];
                    s[i]=s[j];
                    s[j]=temp;
                }
            }
        }
        a[s[0].ID]=1;
        for(int i=1;i<n;i++){
            if(s[i].a==s[i-1].a) a[s[i].ID]=a[s[i-1].ID];
            else a[s[i].ID]=i+1;
        }
    
    
        for(int i=0;i<n;i++){
        for(int j=i;j<n;j++){
                if(s[i].c<s[j].c){
                    temp=s[i];
                    s[i]=s[j];
                    s[j]=temp;
                }
            }
        }
        c[s[0].ID]=1;
        for(int i=1;i<n;i++){
            if(s[i].c==s[i-1].c) c[s[i].ID]=c[s[i-1].ID];
            else c[s[i].ID]=i+1;
        }
    
    
        for(int i=0;i<n;i++){
        for(int j=i;j<n;j++){
                if(s[i].m<s[j].m){
                    temp=s[i];
                    s[i]=s[j];
                    s[j]=temp;
                }
            }
        }
        m[s[0].ID]=1;
        for(int i=1;i<n;i++){
            if(s[i].m==s[i-1].m) m[s[i].ID]=m[s[i-1].ID];
            else m[s[i].ID]=i+1;
        }
    
    
        for(int i=0;i<n;i++){
        for(int j=i;j<n;j++){
                if(s[i].e<s[j].e){
                    temp=s[i];
                    s[i]=s[j];
                    s[j]=temp;
                }
            }
        }
        e[s[0].ID]=1;
        for(int i=1;i<n;i++){
            if(s[i].e==s[i-1].e) e[s[i].ID]=e[s[i-1].ID];
            else e[s[i].ID]=i+1;
        }
    
        for(int i=0;i<k;i++){
            cin>>CID[i];
        }
    
        for(int i=0;i<k;i++){
            int min=2001;
            if (a.count(CID[i])==0) {cout<<"N/A"<<endl;}
            else{
                if(a[CID[i]]<min) {min=a[CID[i]];t='A';}
                if(c[CID[i]]<min) {min=c[CID[i]];t='C';}
                if(m[CID[i]]<min) {min=m[CID[i]];t='M';}
                if(e[CID[i]]<min) {min=e[CID[i]];t='E';}
                cout<<min<<" "<<t<<endl;
            }
        }
    
        return 0;
    }
  • 相关阅读:
    Head of a Gang
    如何实现可以获取最小值的栈?
    多项式函数的极值点与拐点判别及个数公式
    解决Windows10下小娜无法搜索本地应用的问题
    Oracle中常用的语句
    [HTML]在页面中输出空格的几种方式
    [JavaScript]JS中的变量声明与有效域
    JAVA中时间格式转换
    Context initialization failed org.springframework.beans.factory.BeanCreationException
    Spring整合Mybatis SQL语句的输出
  • 原文地址:https://www.cnblogs.com/Qmelbourne/p/6075047.html
Copyright © 2011-2022 走看看